summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-27 16:21:12 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-28 13:58:42 +0100
commit335c9e39024302476edb35b139ba2350a5d76437 (patch)
tree88a7b85f4a80e9f808a4795d086c8bbb83d75a85 /gnu/packages/python.scm
parentbd041e7fd3dbae04d5182afa8e4be4e96cfd8b3e (diff)
downloadguix-335c9e39024302476edb35b139ba2350a5d76437.tar.gz
gnu: python-fixtures: Propagate python-pbr.
* gnu/packages/check.scm (python-fixtures-bootstrap,
python2-fixtures-bootstrap, python-testrepository-bootstrap,
python2-testrepository-bootstrap): New public variables.
(python-fixtures): Adjust accordingly.
(python-testrepository): Likewise.
[native-inputs]: Remove PYTHON-PBR-MINIMAL.
* gnu/packages/python.scm (python-pbr)[native-inputs]: Replace PYTHON-FIXTURES
and PYTHON-TESTREPOSITORY WITH PYTHON-FIXTURES-BOOTSTRAP and
PYTHON-TESTREPOSITORY-BOOTSTRAP.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4ccd6a7359..efe8e8c638 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1689,12 +1689,12 @@ code introspection, and logging.")
     (propagated-inputs
       `(("git" ,git))) ;; pbr actually uses the "git" binary.
     (native-inputs
-      `(("python-fixtures" ,python-fixtures)
+      `(("python-fixtures" ,python-fixtures-bootstrap)
         ;; discover, coverage, hacking, subunit
         ("python-mock" ,python-mock)
         ("python-six" ,python-six)
         ("python-sphinx" ,python-sphinx)
-        ("python-testrepository" ,python-testrepository)
+        ("python-testrepository" ,python-testrepository-bootstrap)
         ("python-testresources" ,python-testresources)
         ("python-testscenarios" ,python-testscenarios)
         ("python-testtools" ,python-testtools)