summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-15 15:26:20 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-15 17:20:57 +0100
commit5c798ca71dcd009896654da7d6a1f8942c6f3c50 (patch)
treec86cc60b0d265d723daa8535370f5df26623cedc /gnu/packages/python.scm
parent4403030b7de2485dbeb6ee54c56551a2bd2b5244 (diff)
downloadguix-5c798ca71dcd009896654da7d6a1f8942c6f3c50.tar.gz
gnu: python: Update to 3.6.4.
* gnu/packages/patches/python-3-search-paths.patch: Adjust context.
* gnu/packages/python.scm (python): Update to 3.6.4.
[source]: Re-enable test_socket.py.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dbb5ccb52e..82639939fd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -338,7 +338,7 @@ data types.")
 
 (define-public python-3.6
   (package (inherit python-2)
-    (version "3.6.3")
+    (version "3.6.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.python.org/ftp/python/"
@@ -351,17 +351,13 @@ data types.")
               (patch-flags '("-p0"))
               (sha256
                (base32
-                "1nl1raaagr4car787a2hmjv2dw6gqny53xfd6wisbgx4r5kxk9yd"))
+                "1fna7g8jxzl4kd2pqmmqhva5724c5m920x3fsrpsgskaylmr76qm"))
               (snippet
                '(begin
                   (for-each delete-file
                             '("Lib/ctypes/test/test_structures.py" ; fails on aarch64
                               "Lib/ctypes/test/test_win32.py" ; fails on aarch64
-                              "Lib/test/test_fcntl.py" ; fails on aarch64
-                              ;; This test fails on kernels older than 4.5.
-                              ;; It is skipped on these kernels in later
-                              ;; versions of Python.
-                              "Lib/test/test_socket.py"))
+                              "Lib/test/test_fcntl.py")) ; fails on aarch64
                   #t))))
     (arguments
      (substitute-keyword-arguments (package-arguments python-2)