summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-01 11:59:01 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-07 10:51:21 +0200
commit2c0499ad876aa9245cd3a4001ee2772a0d2aa03a (patch)
tree55874b6c909030cae787bd192bb941df0fa68889 /gnu/packages/python.scm
parentc267cc15785953cb4140b0901f315052c77f7134 (diff)
downloadguix-2c0499ad876aa9245cd3a4001ee2772a0d2aa03a.tar.gz
gnu: Add python-drmaa.
* gnu/packages/python.scm (python-drmaa, python2-drmaa): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ddd308bce8..59c460af3b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2867,6 +2867,37 @@ etc.  The core of this module is a decorator factory.")
 (define-public python2-decorator
   (package-with-python2 python-decorator))
 
+(define-public python-drmaa
+  (package
+    (name "python-drmaa")
+    (version "0.7.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/d/drmaa/drmaa-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "0bzl9f9g34dlhwf09i3fdv7dqqzf2iq0w7d6c2bafx1nlap8qfbh"))))
+    (build-system python-build-system)
+    ;; The test suite requires libdrmaa which is provided by the cluster
+    ;; environment.  At runtime the environment variable DRMAA_LIBRARY_PATH
+    ;; should be set to the path of the libdrmaa library.
+    (arguments '(#:tests? #f))
+    (native-inputs
+     `(("python-nose" ,python-nose)
+       ("python-setuptools" ,python-setuptools)))
+    (home-page "https://pypi.python.org/pypi/drmaa")
+    (synopsis "Python bindings for the DRMAA library")
+    (description
+      "A Python package for Distributed Resource Management (DRM) job
+submission and control.  This package is an implementation of the DRMAA 1.0
+Python language binding specification.")
+    (license bsd-3)))
+
+(define-public python2-drmaa
+  (package-with-python2 python-drmaa))
+
 (define-public python-ipython
   (package
     (name "python-ipython")