summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorAdam Massmann <massmannak@gmail.com>2018-04-04 02:09:28 -0400
committerEric Bavier <bavier@member.fsf.org>2018-04-04 09:35:15 -0500
commitc2b2f0c86691f6d76f528b6366c866b8f3665c3c (patch)
treeeef120345307d5143256994354883fdab6451394 /gnu/packages/python.scm
parentf0196e82b8848e62816e815df3d3c7d89ac5edea (diff)
downloadguix-c2b2f0c86691f6d76f528b6366c866b8f3665c3c.tar.gz
gnu: Add python-latexcodec
* gnu/packages/python.scm (python-latexcodec): New variable.

Signed-off-by: Eric Bavier <bavier@member.fsf.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3bb6e2b0b7..8d15c9a214 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -49,7 +49,8 @@
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
 ;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
 ;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
-
+;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
+;;;
 ;;; This file is part of GNU Guix.
 ;;;
 ;;; GNU Guix is free software; you can redistribute it and/or modify it
@@ -13081,3 +13082,22 @@ file system events on Linux.")
         (base32
          "0svc9nla3b9145d6b7fb9dizx412l3difzqw0ilh9lz52nsixw8j"))
        (file-name (string-append name "-" version ".tar.gz"))))))
+
+(define-public python-latexcodec
+  (package
+    (name "python-latexcodec")
+    (version "1.0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "latexcodec" version))
+       (sha256
+        (base32
+         "0zdd1gf24i83ykadx0y30n3001j43scqr2saql3vckk5c39dj1wn"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-six" ,python-six)))
+    (home-page "https://readthedocs.org/projects/latexcodec/")
+    (synopsis "Work with LaTeX code in Python")
+    (description "Lexer and codec to work with LaTeX code in Python.")
+    (license license:expat)))