summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-02 15:51:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-02 16:33:57 +0100
commit88bf9be38e32787393cb4c71d79d73c1d1971754 (patch)
tree465b16e2688fbdc40f3c1758913ebc30c6bc2538 /gnu/packages/python.scm
parentfec14302d5b57fe94ebecb78933c6402ebe90414 (diff)
downloadguix-88bf9be38e32787393cb4c71d79d73c1d1971754.tar.gz
gnu: python-ipywidgets: Enable tests.
* gnu/packages/python.scm (python-ipywidgets)[arguments]: Remove.
[native-inputs]: Add python-nose and python-pytest.
[propagated-inputs]: Remove python-ipykernel.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b80ea0ba1f..52fa59329c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7255,13 +7255,13 @@ notebooks.")
         (base32
          "1lk0qrr5l9a0z7qkkn30hv5832whxwxymf1l576fmmad0n7hkxms"))))
     (build-system python-build-system)
-    ;; FIXME: it's not clear how to run the tests.
-    (arguments `(#:tests? #f))
     (propagated-inputs
-     `(("python-ipykernel" ,python-ipykernel)
-       ("python-ipython" ,python-ipython)
+     `(("python-ipython" ,python-ipython)
        ("python-traitlets" ,python-traitlets)
        ("python-widgetsnbextension" ,python-widgetsnbextension)))
+    (native-inputs
+     `(("python-nose" ,python-nose)
+       ("python-pytest" ,python-pytest)))
     (home-page "https://ipython.org")
     (synopsis "IPython HTML widgets for Jupyter")
     (description "Ipywidgets are interactive HTML widgets for Jupyter