summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-10 18:56:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-10 19:43:27 +0300
commit394b8060b187aa55810e285382a97c01c17dcfe6 (patch)
tree505f755ce5ebde4ec694050a26f648f7ed5d2eb9 /gnu/packages/python.scm
parent13f3ff352237e58a91c8aa3b6fe2ddb487a1235e (diff)
downloadguix-394b8060b187aa55810e285382a97c01c17dcfe6.tar.gz
gnu: python-dateutil-2: Update to 2.5.2.
* gnu/packages/python.scm (python-dateutil-2): Update to 2.5.2.
[inputs]: Remove python-setuptools.
[properties]: Define python2-dateutil-2.
(python2-dateutil-2): Build with 'strip-python2-variant'.
[inputs]: Add python2-setuptools.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 72559ec0ee..9b874320a2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -897,28 +897,31 @@ Python file, so it can be easily copied into your project.")
 (define-public python-dateutil-2
   (package
     (name "python-dateutil")
-    (version "2.4.2")
+    (version "2.5.2")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "https://pypi.python.org/packages/source/p/"
-                          name "/" name "-" version ".tar.gz"))
+      (uri (pypi-uri "python-dateutil" version))
       (sha256
        (base32
-        "0ggbm2z72p0nwjqgvpw8s5bqzwayqiqv2iws0x2a605m3mf4959y"))))
+        "0jrfpcgvgya6hs45dhrd9yiqgdgz9qp9aa07zsw8gqgn8zphff86"))))
     (build-system python-build-system)
     (inputs
-     `(("python-setuptools" ,python-setuptools)
-       ("python-six" ,python-six)))
+     `(("python-six" ,python-six)))
     (home-page "http://labix.org/python-dateutil")
     (synopsis "Extensions to the standard datetime module")
     (description
      "The dateutil module provides powerful extensions to the standard
 datetime module, available in Python 2.3+.")
-    (license bsd-3)))
+    (license bsd-3)
+    (properties `((python2-variant . ,(delay python2-dateutil-2))))))
 
 (define-public python2-dateutil-2
-  (package-with-python2 python-dateutil-2))
+  (let ((base (package-with-python2 (strip-python2-variant python-dateutil-2))))
+    (package
+      (inherit base)
+      (inputs `(("python2-setuptools" ,python2-setuptools)
+                ,@(package-inputs base))))))
 
 (define-public python-dateutil
   (package