summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-16 17:36:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-16 17:39:42 +0300
commit7d0c3c8d018a4aff4ce42f863ce81242555ab119 (patch)
tree2793fc3a9ede97a24d83c5f9508977ba6ecebacf /gnu/packages/python.scm
parent8226c2717c9bf5730683ff70a4ffa801d3ac0617 (diff)
downloadguix-7d0c3c8d018a4aff4ce42f863ce81242555ab119.tar.gz
gnu: python-pandas: Update to 0.18.1.
* gnu/packages/python.scm (python-pandas): Update to 0.18.1.
[native-inputs]: Remove python-setuptools.
[properties]: Define python2-pandas.
(python2-pandas)[native-inputs]: Add python2-setuptools.
* gnu/packages/patches/python-pandas-fix-tslib-test-failure.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c6643a6dd6..6eb244356b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -983,15 +983,16 @@ datetime module, available in Python 2.3+.")
 (define-public python-pandas
   (package
     (name "python-pandas")
-    (version "0.18.0")
+    (version "0.18.1")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "pandas" version))
+       (uri (string-append
+              "https://pypi.python.org/packages/11/09/"
+              "e66eb844daba8680ddff26335d5b4fead77f60f957678243549a8dd4830d/"
+              "pandas-" version ".tar.gz"))
        (sha256
-        (base32 "050qw0ap5bhyv5flp78x3lcq1dlminl3xaj6kbrm0jqmx0672xf9"))
-       (patches (search-patches
-                 "python-pandas-fix-tslib-test-failure.patch"))))
+        (base32 "1ckpxrvvjj6zxmn68icd9hib8qcpx9b35f6izxnr25br5ilq7r6j"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-numpy" ,python-numpy)))
@@ -999,8 +1000,7 @@ datetime module, available in Python 2.3+.")
      `(("python-pytz" ,python-pytz)
        ("python-dateutil" ,python-dateutil-2)))
     (native-inputs
-     `(("python-nose" ,python-nose)
-       ("python-setuptools" ,python-setuptools)))
+     `(("python-nose" ,python-nose)))
     (home-page "http://pandas.pydata.org")
     (synopsis "Data structures for data analysis, time series, and statistics")
     (description
@@ -1009,15 +1009,15 @@ structures designed to make working with structured (tabular,
 multidimensional, potentially heterogeneous) and time series data both easy
 and intuitive.  It aims to be the fundamental high-level building block for
 doing practical, real world data analysis in Python.")
-    (license bsd-3)))
+    (license bsd-3)
+    (properties `((python2-variant . ,(delay python2-pandas))))))
 
 (define-public python2-pandas
-  (let ((pandas (package-with-python2 python-pandas)))
-    (package (inherit pandas)
-             (propagated-inputs
-              `(("python2-numpy" ,python2-numpy)
-                ,@(alist-delete "python-numpy"
-                                (package-propagated-inputs pandas)))))))
+  (let ((base (package-with-python2 (strip-python2-variant python-pandas))))
+    (package
+      (inherit base)
+      (native-inputs `(("python2-setuptools" ,python2-setuptools)
+                       ,@(package-inputs base))))))
 
 (define-public python-tzlocal
   (package