summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-05-15 11:51:54 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-19 14:51:21 +0200
commit458480235b85ce31db5485251f94415cfdddeff0 (patch)
treeb9ea894479002c74dc1db794cecc5fa9941fbd83 /gnu/packages/python.scm
parent39b3033731283b81ae36f022c6476634ab1d0455 (diff)
downloadguix-458480235b85ce31db5485251f94415cfdddeff0.tar.gz
gnu: python: Add 'python' variables for different major/minor versions.
* gnu/packages/python.scm (python-2): Rename variable to...
  (python-2.7): ...this.
  (python-2): Refer to "python-2.7".
  (python): Rename variable to...
  (python-3.4): ...this.
  (python-3): Refer to "python-3.4".
  (python): Refer to "python-3".

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1929f83a16..37c8594a37 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -90,7 +90,7 @@
   #:use-module (guix build-system trivial)
   #:use-module (srfi srfi-1))
 
-(define-public python-2
+(define-public python-2.7
   (package
     (name "python")
     (version "2.7.10")
@@ -262,7 +262,10 @@ packages; exception-based error handling; and very high level dynamic
 data types.")
     (license psfl)))
 
-(define-public python
+;; Current 2.x version.
+(define-public python-2 python-2.7)
+
+(define-public python-3.4
   (package (inherit python-2)
     (version "3.4.3")
     (source (origin
@@ -288,6 +291,12 @@ data types.")
                                         (version-major+minor version)
                                         "/site-packages"))))))))
 
+;; Current 3.x version.
+(define-public python-3 python-3.4)
+
+;; Current major version.
+(define-public python python-3)
+
 ;; Minimal variants of Python, mostly used to break the cycle between Tk and
 ;; Python (Tk -> libxcb -> Python.)