summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-23 16:01:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-23 16:01:07 +0100
commit72ffb5123159ab403b2882d6b6b90609fa49136b (patch)
tree16d159846a3a0e614a624d1ecc7af5df695d4714 /gnu/packages/python.scm
parent93d229cb868575b2c89bea2b4f61214d0838fe8b (diff)
downloadguix-72ffb5123159ab403b2882d6b6b90609fa49136b.tar.gz
gnu: Add python-objgraph.
* gnu/packages/python.scm (python-objgraph): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 569a1a5732..3b6259c48a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9081,6 +9081,30 @@ are synchronized with data exchanges on \"channels\".")
 (define-public python2-greenlet
   (package-with-python2 python-greenlet))
 
+(define-public python-objgraph
+  (package
+    (name "python-objgraph")
+    (version "3.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "objgraph" version))
+       (sha256
+        (base32
+         "184m09am5gpbqfaiy7l0hwh476mczbrly1dffs0rw2p1d1i2q32a"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-graphviz" ,python-graphviz)))
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("graphviz" ,graphviz)))
+    (home-page "https://mg.pov.lt/objgraph/")
+    (synopsis "Draw Python object reference graphs with graphviz")
+    (description
+     "This package provides tools to draw Python object reference graphs with
+graphviz.")
+    (license license:expat)))
+
 (define-public python-gevent
   (package
     (name "python-gevent")