summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-17 20:12:32 -0400
committerLeo Famulari <leo@famulari.name>2016-10-19 14:36:51 -0400
commit7ffa5d4a2da7041712c9b6485923f2c3ee455f82 (patch)
tree2547b721a0811e37af131b1d4a76add0456346d9 /gnu/packages/python.scm
parent00bf74be0578fda2cd662ee6dd75ee18c9112f48 (diff)
downloadguix-7ffa5d4a2da7041712c9b6485923f2c3ee455f82.tar.gz
gnu: python-file: Work around "double encoding" bug in file@5.28.
* gnu/packages/patches/python-file-double-encoding-bug.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/python.scm (python-file)[source]: Use it.
(python2-file)[source]: Use the source of FILE directly, without the
patch.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f91747903f..559bdc69f0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6459,6 +6459,10 @@ Python's @code{ctypes} foreign function interface (FFI).")
   (package
     (inherit file)
     (name "python-file")
+    (source (origin
+              (inherit (package-source file))
+              ;; This patch should not be applied to python2-file.
+              (patches (search-patches "python-file-double-encoding-bug.patch"))))
     (build-system python-build-system)
     (arguments
      '(#:tests? #f                                ;no tests
@@ -6487,6 +6491,7 @@ serve the same purpose: provide Python bindings for libmagic.")
   (let ((base (package-with-python2 (strip-python2-variant python-file))))
     (package
       (inherit base)
+      (source (package-source file))
       (native-inputs
        `(("python2-setuptools" ,python2-setuptools)
          ,@(package-native-inputs base))))))