summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-11 11:07:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-11 11:13:56 +0200
commit8189ce6f05ebc49fc85934bdd1c81f8d43496a93 (patch)
tree957d559e68b445bbc200f9be459bf5de12e5c439 /gnu/packages/python.scm
parent95176544d54cbc8c7c2bacd96e19b4a1411afbff (diff)
downloadguix-8189ce6f05ebc49fc85934bdd1c81f8d43496a93.tar.gz
gnu: python-pyclipper: Update to 1.1.0post1.
* gnu/packages/python.scm (python-pyclipper): Update to 1.1.0post1.
[source]: Add snippet to remove cythonized source files.
[arguments]: Add custom phase to generate cythonized files.
[native-inputs]: Add python-cython.
[description]: Update clipper library version.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 17 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f4592829a0..e8d8daae40 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12896,26 +12896,38 @@ belong to tagged versions.")
 (define-public python-pyclipper
   (package
     (name "python-pyclipper")
-    (version "1.0.6")
+    (version "1.1.0.post1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pyclipper" version ".zip"))
        (sha256
         (base32
-         "1zpmwv3bya3j984y5cf9x9d5108kf6mxldcba68wiq0frv5qrssw"))))
+         "0ldbkbnx94an4zzrwb1sxmg6k0jgk4cwmvcdyy8y5k1zslc612wa"))
+      (modules '((guix build utils)))
+      (snippet
+       '(begin
+          ;; This file is generated by Cython.
+          (delete-file "pyclipper/pyclipper.cpp") #t))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f)); 8 Tests fail, 37 succeed
+     `(#:tests? #f  ; 8 Tests fail, 37 succeed
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'cythonize-sources
+           (lambda _
+             (with-directory-excursion "pyclipper"
+               (invoke "cython" "--cplus" "pyclipper.pyx")))))))
     (propagated-inputs
      `(("python-setuptools-scm-git-archive" ,python-setuptools-scm-git-archive)))
     (native-inputs
-     `(("unzip" ,unzip)))
+     `(("python-cython" ,python-cython)
+       ("unzip" ,unzip)))
     (home-page "https://github.com/greginvm/pyclipper")
     (synopsis "Wrapper for Angus Johnson's Clipper library")
     (description
      "Pyclipper is a Cython wrapper for the C++ translation of the
-  Angus Johnson's polygon clipping Clipper library (ver. 6.2.1).")
+Angus Johnson's polygon clipping Clipper library (ver. 6.4.2).")
     (license license:expat)))
 
 (define-public python2-pyclipper