summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-04 13:50:22 -0500
committerLeo Famulari <leo@famulari.name>2018-01-05 13:52:05 -0500
commit6a25c6cd1316371ecf9c08a5c9c73704c2db900a (patch)
treef35f66e621e157c114bdc0dab85b5e02b5ef0807 /gnu/packages/python.scm
parent6149fdfb5e97e3598e08b6516a96d647a14f03a6 (diff)
downloadguix-6a25c6cd1316371ecf9c08a5c9c73704c2db900a.tar.gz
gnu: python-click: Disable the test suite.
* gnu/packages/python.scm (python-click, python2-click)[arguments]: Skip
the tests.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b7e1d3e2dc..906ab2b3ee 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1704,7 +1704,10 @@ files.")
          "02qkfpykbq35id8glfgwc38yc430427yd05z1wc5cnld8zgicmgi"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
+     `(;; The tests are fragile, depending on a specific version of pytest:
+       ;; <https://github.com/pallets/click/issues/823>
+       #:tests? #f
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-paths
            (lambda* (#:key inputs #:allow-other-keys)
@@ -1713,10 +1716,7 @@ files.")
                (substitute* "click/_unicodefun.py"
                  (("'locale'")
                   (string-append "'" glibc "/bin/locale'"))))
-             #t))
-         (replace 'check
-           (lambda _
-             (zero? (system* "make" "test")))))))
+             #t)))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (home-page "http://click.pocoo.org")