summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 14:44:38 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:57:29 +0200
commita17ccbbb12eddda9aeb43ec8e004d716c15af4da (patch)
treed3f545724d9c4263f85f4d25d8362a0f7102aceb /gnu/packages/python.scm
parente139c7a742aa40c891bc04b70fdd6c8669c1ea7b (diff)
downloadguix-a17ccbbb12eddda9aeb43ec8e004d716c15af4da.tar.gz
gnu: Add python-levenshtein.
* gnu/packages/python.scm (python-levenshtein, python2-levenshtein):
New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3503eccd92..79615862f2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14386,3 +14386,31 @@ this it tries to be opinion-free and very extendable.")
 
 (define-public python2-elasticsearch
   (package-with-python2 python-elasticsearch))
+
+(define-public python-levenshtein
+  (package
+    (name "python-levenshtein")
+    (version "0.12.0")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (pypi-uri "python-Levenshtein" version))
+      (sha256
+       (base32
+        "1c9ybqcja31nghfcc8xxbbz9h60s9qi12b9hr4jyl69xbvg12fh3"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/ztane/python-Levenshtein")
+    (synopsis "Fast computation of Levenshtein distance and string similarity")
+    (description
+     "The Levenshtein Python C extension module contains functions for fast computation of
+@enumerate
+@item Levenshtein (edit) distance, and edit operations
+@item string similarity
+@item approximate median strings, and generally string averaging
+@item string sequence and set similarity
+@end enumerate
+It supports both normal and Unicode strings.")
+    (license license:gpl2+)))
+
+(define-public python2-levenshtein
+  (package-with-python2 python-levenshtein))