summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-30 00:11:38 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commitd7e729fe08284b15aee074eb61c964953c04d0a2 (patch)
treebda5139d6d34c867e4a1ebcd1aad6d306c68a686 /gnu/packages/python.scm
parent6720dbb49f2ac8fdffa68a9816a79a4c39b56f65 (diff)
downloadguix-d7e729fe08284b15aee074eb61c964953c04d0a2.tar.gz
gnu: Add python-pytest-localserver.
* gnu/packages/python.scm (python-pytest-localserver): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6d9289b3db..d45db218e1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6850,3 +6850,33 @@ minimal and fast API targetting the following uses:
 the last py.test invocation.")
     (home-page "https://bitbucket.org/hpk42/pytest-cache/")
     (license license:expat)))
+
+(define-public python-pytest-localserver
+  (package
+    (name "python-pytest-localserver")
+    (version "0.3.4")
+    (source (origin
+             (method url-fetch)
+             (uri (pypi-uri "pytest-localserver" version ".zip"))
+             (sha256
+              (base32
+               "050q505a7gnsz7vqidw0w5dvxjb2flzi7z734agpjzmsl85c2bcx"))))
+    (build-system python-build-system)
+    (arguments
+      `(#:phases (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (zero? (system* "py.test" "--genscript=runtests.py"))
+             (zero? (system* "py.test")))))))
+    (native-inputs
+     `(("unzip" ,unzip)))
+    (propagated-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-requests" ,python-requests)
+       ("python-six" ,python-six)
+       ("python-werkzeug" ,python-werkzeug)))
+    (synopsis "Py.test plugin to test server connections locally")
+    (description "Pytest-localserver is a plugin for the pytest testing
+framework which enables you to test server connections locally.")
+    (home-page "https://pypi.python.org/pypi/pytest-localserver")
+    (license license:expat)))