summary refs log tree commit diff
path: root/gnu/packages/qemu.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-08-18 22:23:57 -0400
committerMark H Weaver <mhw@netris.org>2015-08-18 23:57:25 -0400
commit7cb6f648b2486b0e6060a333564432a0830637de (patch)
treebe5152f2b7171f58bf9cfa8036536dccee8d810f /gnu/packages/qemu.scm
parent2376963411a096aa0c8e77f27c4d1db1a9a7fa42 (diff)
downloadguix-7cb6f648b2486b0e6060a333564432a0830637de.tar.gz
gnu: qemu: Update to 2.3.1. Add fix for CVE-2015-5745.
* gnu/packages/patches/qemu-CVE-2015-5745.patch: New file.
* gnu/packages/patches/qemu-CVE-2015-3456.patch,
  gnu/packages/patches/qemu-CVE-2015-5154-pt1.patch,
  gnu/packages/patches/qemu-CVE-2015-5154-pt2.patch,
  gnu/packages/patches/qemu-CVE-2015-5154-pt3.patch,
  gnu/packages/patches/qemu-CVE-2015-5158.patch: Delete files.
* gnu-system.am (dist_patch_DATA): Add new file and remove the deleted ones.
* gnu/packages/qemu.scm (qemu): Update to 2.3.1.  Add new patch and remove the
  deleted ones.
Diffstat (limited to 'gnu/packages/qemu.scm')
-rw-r--r--gnu/packages/qemu.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index 6979655122..b2ef95d03b 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -44,16 +44,15 @@
   ;; This is QEMU without GUI support.
   (package
     (name "qemu-headless")
-    (version "2.3.0")
+    (version "2.3.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "http://wiki.qemu-project.org/download/qemu-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "120m53c3p28qxmfzllicjzr8syjv6v4d9rsyrgkp7gnmcgvvgfmn"))
+               "0px1vhkglxzjdxkkqln98znv832n1sn79g5inh3aw72216c047b6"))
              (patches (map search-patch '("qemu-CVE-2015-3209.patch"
-                                          "qemu-CVE-2015-3456.patch"
                                           "qemu-CVE-2015-4037.patch"
                                           "qemu-CVE-2015-4103.patch"
                                           "qemu-CVE-2015-4104.patch"
@@ -66,10 +65,7 @@
                                           "qemu-CVE-2015-4106-pt6.patch"
                                           "qemu-CVE-2015-4106-pt7.patch"
                                           "qemu-CVE-2015-4106-pt8.patch"
-                                          "qemu-CVE-2015-5154-pt1.patch"
-                                          "qemu-CVE-2015-5154-pt2.patch"
-                                          "qemu-CVE-2015-5154-pt3.patch"
-                                          "qemu-CVE-2015-5158.patch")))))
+                                          "qemu-CVE-2015-5745.patch")))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (alist-replace