summary refs log tree commit diff
path: root/gnu/packages/qemu.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-28 01:14:34 +0100
committerLudovic Courtès <ludo@gnu.org>2014-10-28 01:18:50 +0100
commitf47638a3534c99fb8fef501c5827e9e32a6b4a2e (patch)
tree4611841beeff27a83c78b98f776fdcf1a574e789 /gnu/packages/qemu.scm
parent2d7bf949277a0889ced8aa486c4ef16cb7cf6b1a (diff)
downloadguix-f47638a3534c99fb8fef501c5827e9e32a6b4a2e.tar.gz
gnu: Mark a few packages as unsupported on MIPS.
* gnu/packages/gprolog.scm (gprolog): Add 'supported-systems' field.
* gnu/packages/qemu.scm (qemu-headless): Likewise.
* gnu/packages/qt.scm (qt): Likewise.
* gnu/packages/scheme.scm (racket): Likewise.
Diffstat (limited to 'gnu/packages/qemu.scm')
-rw-r--r--gnu/packages/qemu.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index 33d23572bd..75a14b6e8f 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -125,7 +125,10 @@ the KVM kernel module in Linux.  When using KVM, QEMU can virtualize x86,
 server and embedded PowerPC, and S390 guests.")
 
     ;; Many files are GPLv2+, but some are GPLv2-only---e.g., `memory.c'.
-    (license gpl2)))
+    (license gpl2)
+
+    ;; Several tests fail on MIPS; see <http://hydra.gnu.org/build/117914>.
+    (supported-systems (delete "mips64el-linux" %supported-systems))))
 
 (define-public qemu
   ;; QEMU with GUI support.