summary refs log tree commit diff
path: root/gnu/packages/qemu.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-13 14:05:11 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:05 +0100
commit482d95918e2a9de05ee224d979c15759e54febf0 (patch)
tree578cba1bd70c924ad4027a9aa31716d7dd1e87c2 /gnu/packages/qemu.scm
parentdae73d9b9a4db932e8c7c1b7607981dc6cb401a5 (diff)
downloadguix-482d95918e2a9de05ee224d979c15759e54febf0.tar.gz
gnu: Fix python inputs, part 5: some inputs become propagated-inputs
* gnu/packages/openstack.scm
  (python-os-client-config)[inputs] change to
  [native-inputs]. [propagated-inputs]: New element, move python-appdirs,
  python-pyyaml here.
  (python-git-review)[propagated-inputs]: New element, move python-requests
  here.
* gnu/packages/python.scm
  (python-rpy2)[propagated-inputs]: New element, move python-six here.
  (python-xcffib)[inputs] move python-six to [propagated-inputs].
  (python-flake8)[propagated-inputs]: New element, move python-pep8,
  python-pyflakes, python-mccabe here.
  (python-flake8-2.2.4)[propagated-inputs]: New element, move python-pep8,
  python-pyflakes, python-mccabe here.
  (python-pytest)[propagated-inputs]: New element, move python-py here.
  (python-tox)[propagated-inputs]: New element, move all inputs except of
  python-pytest here.
  (python-botocore)[propagated-inputs]: New element, move python-dateutil,
  python-docutils, python-jmespath here.
  (awscli)[propagated-inputs]: New element, move python-colorama,
  python-botocore, python-s3transfer, python-docutils, python-rsa here.
  (python-mako)[propagated-inputs]: New element, move python-markupsafe here.
* gnu/packages/qemu.scm(python-libvirt)[propagated-inputs]: New element, move
  python-lxml here.
Diffstat (limited to 'gnu/packages/qemu.scm')
-rw-r--r--gnu/packages/qemu.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index f6e34cace4..332e2ad0ef 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -395,8 +395,9 @@ three libraries:
                                (which "nosetests") "\"")))
              #t)))))
     (inputs
-     `(("libvirt" ,libvirt)
-       ("python-lxml" ,python-lxml)))
+     `(("libvirt" ,libvirt)))
+    (propagated-inputs
+     `(("python-lxml" ,python-lxml)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python-nose" ,python-nose)))