summary refs log tree commit diff
path: root/gnu/packages/qemu.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-16 10:47:36 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-16 10:47:36 +0200
commitb344c505f4dff2ecbe981f0a0a3c3d67b222dcca (patch)
treee4c626e8aa23c1ce87ebc0f47eb8714dc555679d /gnu/packages/qemu.scm
parent7190ae7743f84c78ec689e0ff1059cfbdcf3cb66 (diff)
downloadguix-b344c505f4dff2ecbe981f0a0a3c3d67b222dcca.tar.gz
gnu: qemu: Remove dependency on Samba.
* gnu/packages/qemu.scm (qemu-headless)[inputs]: Remove SAMBA.
  [arguments]: Remove --smbd configure flag.
Diffstat (limited to 'gnu/packages/qemu.scm')
-rw-r--r--gnu/packages/qemu.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index b4a962e888..f3c2ed9d2b 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -34,7 +34,6 @@
   #:use-module (gnu packages libjpeg)
   #:use-module (gnu packages attr)
   #:use-module (gnu packages linux)
-  #:use-module (gnu packages samba)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages sdl)
@@ -59,8 +58,7 @@
                  (lambda* (#:key inputs outputs #:allow-other-keys)
                    ;; The `configure' script doesn't understand some of the
                    ;; GNU options.  Thus, add a new phase that's compatible.
-                   (let ((out   (assoc-ref outputs "out"))
-                         (samba (assoc-ref inputs "samba")))
+                   (let ((out (assoc-ref outputs "out")))
                      (setenv "SHELL" (which "bash"))
 
                      ;; While we're at it, patch for tests.
@@ -74,9 +72,7 @@
                                (string-append "--cc=" (which "gcc"))
                                "--disable-debug-info" ; save build space
                                "--enable-virtfs"      ; just to be sure
-                               (string-append "--prefix=" out)
-                               (string-append "--smbd=" samba
-                                              "/sbin/smbd")))))
+                               (string-append "--prefix=" out)))))
                  (alist-cons-after
                   'install 'install-info
                   (lambda* (#:key inputs outputs #:allow-other-keys)
@@ -108,8 +104,7 @@
        ;; ("pciutils" ,pciutils)
        ("alsa-lib" ,alsa-lib)
        ("zlib" ,zlib)
-       ("attr" ,attr)
-       ("samba" ,samba)))                         ; an optional dependency
+       ("attr" ,attr)))
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("python" ,python-2) ; incompatible with Python 3 according to error message
                      ("texinfo" ,texinfo)