summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-17 23:47:28 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-31 21:55:45 -0400
commit65e5e85d284ef78bc245b3779c7fcdc733ed60a7 (patch)
treec2646edee49544e610d5f71c2bb736d70abf9d08 /gnu/packages/qt.scm
parent397d05a4bf680372e3ebdb83e388c9f672a0e90b (diff)
downloadguix-65e5e85d284ef78bc245b3779c7fcdc733ed60a7.tar.gz
gnu: qtquickcontrols: Rename to qtquickcontrols-5.
Automated via:

  git grep -l qtquickcontrols | xargs sed 's/\bqtquickcontrols\b/\0-5/g' -i
  git checkout NEWS
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 708de406c4..fb6fb5245c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1587,7 +1587,7 @@ native APIs where it makes sense.")))
      (substitute-keyword-arguments (package-arguments qtsvg-5)
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
     (native-inputs
-     (list perl qtdeclarative-5 qtquickcontrols qtserialport))
+     (list perl qtdeclarative-5 qtquickcontrols-5 qtserialport))
     (inputs
      (list icu4c openssl qtbase-5 zlib))
     (synopsis "Qt Location and Positioning modules")
@@ -1636,7 +1636,7 @@ that helps in Qt development.")))
 The following guides and references cover aspects of programming with
 ECMAScript and Qt.")))
 
-(define-public qtquickcontrols
+(define-public qtquickcontrols-5
   (package (inherit qtsvg-5)
     (name "qtquickcontrols")
     (version "5.15.2")
@@ -3268,7 +3268,7 @@ color-related widgets.")
            qtdeclarative-5
            qtlocation
            qtmultimedia-5
-           qtquickcontrols
+           qtquickcontrols-5
            qtquickcontrols2
            qtscript
            qtscxml
@@ -3317,7 +3317,7 @@ color-related widgets.")
                                 "qtdeclarative-5"
                                 "qtlocation"
                                 "qtmultimedia-5"
-                                "qtquickcontrols"
+                                "qtquickcontrols-5"
                                 "qtquickcontrols2"
                                 "qtscript"
                                 "qtscxml"