summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-18 07:57:16 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-31 21:55:47 -0400
commita0beb297a352930b89051ff258a06d78f224d6b9 (patch)
treefef76045d5d8897360901de2ffa5e81bed12c439 /gnu/packages/qt.scm
parentef648459df868be6a44c7bfdb491e8e50bb9bfc6 (diff)
downloadguix-a0beb297a352930b89051ff258a06d78f224d6b9.tar.gz
gnu: qtwebengine: Rename to qtwebengine-5.
Automated with:

  git grep -l qtwebengine | xargs sed 's/\bqtwebengine\b/\0-5/g' -i
  git checkout NEWS
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 3f1f468b7e..3450efe08b 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2011,7 +2011,7 @@ using the Enchant spell-checking library.")
     ;; COPYING file specify GPL3, but source code files all refer to GPL2+.
     (license license:gpl2+)))
 
-(define-public qtwebengine
+(define-public qtwebengine-5
   (package
     (inherit qtsvg-5)
     (name "qtwebengine")
@@ -2206,7 +2206,7 @@ using the Enchant spell-checking library.")
                  (_ #t)))
 
              (with-directory-excursion "src/3rdparty"
-               ;; TODO: Try removing "gn" too for future versions of qtwebengine.
+               ;; TODO: Try removing "gn" too for future versions of qtwebengine-5.
                (delete-file-recursively "ninja")
 
                (with-directory-excursion "chromium"
@@ -2324,7 +2324,7 @@ using the Enchant spell-checking library.")
                     (display "\ngn_args += use_system_openh264=true\n" out)))
                  ;; Qtwebengine is not installed into the same prefix as
                  ;; qtbase.  Some qtbase QTLibraryInfo constants will not
-                 ;; work.  Replace with the full path to the qtwebengine
+                 ;; work.  Replace with the full path to the qtwebengine-5
                  ;; translations and locales in the store.
                  (substitute* "src/core/web_engine_library_info.cpp"
                    (("QLibraryInfo::location\\(QLibraryInfo::TranslationsPath\\)")
@@ -2354,7 +2354,7 @@ using the Enchant spell-checking library.")
                (invoke "qmake" "QT_BUILD_PARTS = libs tools" "--"
                        "--webengine-printing-and-pdf=no"
                        "--webengine-ffmpeg=system"
-                       ;; FIXME: Building qtwebengine 5.12.2 with
+                       ;; FIXME: Building qtwebengine-5 5.12.2 with
                        ;; icu4c >= 68 fails.
                        ;;"--webengine-icu=system"
                        "--webengine-pepper-plugins=no"
@@ -2647,7 +2647,7 @@ contain over 620 classes.")
        ("qtsvg-5" ,qtsvg-5)
        ("qtdeclarative-5" ,qtdeclarative-5)
        ("qtwebchannel-5" ,qtwebchannel-5)
-       ("qtwebengine" ,qtwebengine)))
+       ("qtwebengine-5" ,qtwebengine-5)))
     (arguments
      `(#:modules ((srfi srfi-1)
                   ((guix build python-build-system) #:select (python-version))
@@ -3358,7 +3358,7 @@ color-related widgets.")
            qtspeech
            qtsvg-5
            qtwebchannel-5
-           qtwebengine
+           qtwebengine-5
            qtwebsockets-5
            qtx11extras
            qtxmlpatterns))
@@ -3408,7 +3408,7 @@ color-related widgets.")
                                 "qtsvg-5"
                                 "qttools"
                                 "qtwebchannel-5"
-                                "qtwebengine"
+                                "qtwebengine-5"
                                 "qtwebsockets-5"
                                 "qtx11extras"
                                 "qtxmlpatterns"))))