summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-18 06:21:00 -0800
committerEfraim Flashner <efraim@flashner.co.il>2019-12-19 10:36:08 +0200
commit162cc7f8a499849ccdaedadfa406e1819b0478a6 (patch)
tree04b33a00cda07aab820747e81c753a2ac520944b /gnu/packages/qt.scm
parent4176300804a50d0a1a118ff2ff8b33118dc5b0a1 (diff)
downloadguix-162cc7f8a499849ccdaedadfa406e1819b0478a6.tar.gz
gnu: Fix python-shiboken-2.
* gnu/packages/qt.scm (python-shiboken-2)[inputs]: Remove llvm-6,
clang-6. Add clang-toolchain-6.
[arguments]: Adjust for change in inputs.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index c0d652a407..747d5437e2 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2107,8 +2107,7 @@ color-related widgets.")
            "0g8jacm2iqd7lw2m7f1dp1nnrsk38bl3m8pihm8zz9gxs8d31sf5"))))
       (build-system cmake-build-system)
       (inputs
-       `(("llvm-6" ,llvm-6)
-         ("clang-6" ,clang-6)
+       `(("clang-toolchain" ,clang-toolchain-6)
          ("libxml2" ,libxml2)
          ("libxslt" ,libxslt)
          ("python-wrapper" ,python-wrapper)
@@ -2124,7 +2123,7 @@ color-related widgets.")
              (lambda _ (chdir "sources/shiboken2") #t))
            (add-before 'configure 'set-build-env
              (lambda* (#:key inputs #:allow-other-keys)
-               (let ((llvm (assoc-ref inputs "llvm-6")))
+               (let ((llvm (assoc-ref inputs "clang-toolchain")))
                  (setenv "CLANG_INSTALL_DIR" llvm)
                  #t))))))
       (home-page "https://wiki.qt.io/Qt_for_Python")