summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-02 15:38:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-21 10:03:09 +0200
commit9f8fee5027f622a18b38b8b15a37d3731a3aff68 (patch)
treea17240542c397a118dc5baa02a882240fa8b31e2 /gnu/packages/qt.scm
parentd4274628a63bd5fc73a1ef02855dcff9a8fada3f (diff)
downloadguix-9f8fee5027f622a18b38b8b15a37d3731a3aff68.tar.gz
gnu: qscintilla: Update to 2.10.8.
* gnu/packages/qt.scm (qscintilla): Update to 2.10.8.
(python-qscintilla)[arguments]: Update custom 'configure phase.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm32
1 files changed, 17 insertions, 15 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index f4fd5680b7..8c376bf259 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1917,7 +1917,7 @@ contain over 620 classes.")
 (define-public qscintilla
   (package
     (name "qscintilla")
-    (version "2.10.7")
+    (version "2.10.8")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/pyqt/QScintilla2/"
@@ -1925,7 +1925,7 @@ contain over 620 classes.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "06hs6civq13dvzlws0spjb7gwyk6kynpnfwg5plhahnxf7g5h137"))))
+                "1swjr786w04r514pry9pn32ivza4il1cg35s60qy39cwc175pka6"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -1973,19 +1973,21 @@ indicators, code completion and call tips.")
        #:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda* (#:key outputs configure-flags #:allow-other-keys)
-             (chdir "Python")
-             (apply invoke "python3" "configure.py"
-                    configure-flags)
-             ;; Install to the right directory
-             (substitute* '("Makefile"
-                            "Qsci/Makefile")
-               (("\\$\\(INSTALL_ROOT\\)/gnu/store/[^/]+")
-                (assoc-ref outputs "out")))
-             ;; And fix the installed.txt file
-             (substitute* "installed.txt"
-               (("/gnu/store/[^/]+")
-                (assoc-ref outputs "out")))
+           (lambda* (#:key inputs outputs configure-flags #:allow-other-keys)
+             (let ((out    (assoc-ref outputs "out"))
+                   (python (assoc-ref inputs "python")))
+               (chdir "Python")
+               (apply invoke "python3" "configure.py"
+                      configure-flags)
+               ;; Install to the right directory
+               (substitute* '("Makefile"
+                              "Qsci/Makefile")
+                 (("\\$\\(INSTALL_ROOT\\)/gnu/store/[^/]+") out)
+                 (((string-append python "/lib"))
+                  (string-append out "/lib")))
+               ;; And fix the installed.txt file
+               (substitute* "installed.txt"
+                 (("/gnu/store/[^/]+") out)))
              #t)))))
     (inputs
      `(("qscintilla" ,qscintilla)