summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-02-20 20:20:22 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-02-22 09:38:14 +0800
commitd9368572abd3683bed4263eb5e149bb404baee59 (patch)
treea405507588bd6f7fd187d48f01018e19e1f3ab99 /gnu/packages/qt.scm
parentfbbbc2088ce933d83f5b0be75308fdcb6b40fa57 (diff)
downloadguix-d9368572abd3683bed4263eb5e149bb404baee59.tar.gz
qtwebengine-5: Enable pulseaudio.
Previously it will dlopen libpulse, then fallback to alsa.
See also <https://issues.guix.gnu.org/45280>.

* gnu/packages/qt.scm (qtwebengine-5)[arguments]: Set link_pulseaudio with gn_args.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 76e9e519c7..01327f6ccf 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2708,7 +2708,8 @@ using the Enchant spell-checking library.")
                   "src/buildtools/config/linux.pri"
                   (lambda (in out)
                     (display (get-string-all in) out)
-                    (display "\ngn_args += use_system_openh264=true\n" out)))
+                    (display "\ngn_args += use_system_openh264=true\n" out)
+                    (display "\ngn_args += link_pulseaudio = true\n" out)))
                  ;; Qtwebengine is not installed into the same prefix as
                  ;; qtbase.  Some qtbase QTLibraryInfo constants will not
                  ;; work.  Replace with the full path to the qtwebengine-5