summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-08-01 23:54:43 +0200
committerAndreas Enge <andreas@enge.fr>2016-08-04 01:19:12 +0200
commit7972d8a2e98af6592050a37036c2c80a01358fcf (patch)
tree89771454c3d1052e5086a77e44f3a241bb8791ee /gnu/packages/qt.scm
parent0ea179fd92bc4819e8705eedde822daae6a61bb0 (diff)
downloadguix-7972d8a2e98af6592050a37036c2c80a01358fcf.tar.gz
gnu: qtbase: Modify .cmake files to enable modules in different packages.
* gnu/packages/qt.scm (qtbase)[arguments]: In the configure phase, modify
.cmake and .cmake.in files so that find_package honors CMAKE_PREFIX_PATH.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index f2465509ec..d1701c603e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -393,6 +393,13 @@ developers using C++ or QML, a CSS & JavaScript like language.")
                  (("/bin/pwd") (which "pwd")))
                (substitute* "src/corelib/global/global.pri"
                  (("/bin/ls") (which "ls")))
+               ;; The configuration files for other Qt5 packages are searched
+               ;; through a call to "find_package" in Qt5Config.cmake, which
+               ;; disables the use of CMAKE_PREFIX_PATH via the parameter
+               ;; "NO_DEFAULT_PATH". Re-enable it so that the different
+               ;; components can be installed in different places.
+               (substitute* (find-files "." ".*\\.cmake")
+                 (("NO_DEFAULT_PATH") ""))
                ;; do not pass "--enable-fast-install", which makes the
                ;; configure process fail
                (zero? (system*