summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-01-05 19:27:17 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-09 16:03:56 +0100
commit3e10b2418dc0952c16053ccced4baba405facb6b (patch)
tree78717fe499f1644a016c1c18a501075d041a15d8 /gnu/packages/qt.scm
parente05471a1a9a8d147e11a8e729bccca4b30b9bfbc (diff)
downloadguix-3e10b2418dc0952c16053ccced4baba405facb6b.tar.gz
gnu: qtxmlpatterns: Build QML plugin for XmlListModel.
* gnu/packages/qt.scm (qtdeclarative)[native-inputs]: Remove qtxmlpatterns.
  (qtxmlpatterns)[native-inputs]: Add qtdeclarative.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 795b5e9d2b..daa35c77cb 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -723,6 +723,7 @@ from within Qt 5.")))
                "1l44476ibb8rv4rf80vbjdc3712lmrl1xcxswa513ip66k47p5vn"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
+       ((#:tests? _ #f) #f) ; TODO: Enable the tests
        ((#:phases phases)
         `(modify-phases ,phases
            (add-after 'unpack 'disable-network-tests
@@ -730,7 +731,8 @@ from within Qt 5.")))
                          (("qxmlquery") "# qxmlquery")
                          (("xmlpatterns ") "# xmlpatterns"))
                #t))))))
-    (native-inputs `(("perl" ,perl)))
+    (native-inputs `(("perl" ,perl)
+                     ("qtdeclarative" ,qtdeclarative)))
     (inputs `(("qtbase" ,qtbase)))
     (synopsis "Qt XML patterns module")
     (description "The QtXmlPatterns module is a XQuery and XPath engine for
@@ -758,8 +760,7 @@ xmlpatternsvalidator.")))
        ("pkg-config" ,pkg-config)
        ("python" ,python)
        ("python-wrapper" ,python-wrapper)
-       ("qtsvg" ,qtsvg)
-       ("qtxmlpatterns" ,qtxmlpatterns)))
+       ("qtsvg" ,qtsvg)))
     (inputs
      `(("mesa" ,mesa)
        ("qtbase" ,qtbase)))