summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-04 19:56:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-06 00:08:05 -0400
commit2b1cf6906d521d74802577f5c691bba0bb9b4088 (patch)
tree8fe8750d530e27c307c9c9c992710ab8635b6d2b /gnu/packages/qt.scm
parentddea1161ad164e0f7a1674cffa9256b01b31467c (diff)
downloadguix-2b1cf6906d521d74802577f5c691bba0bb9b4088.tar.gz
gnu: qtwebengine: Fix build.
The package was not really building; the build phase was failing silently and
no libraries were installed to the output.

* gnu/packages/qt.scm (qtwebengine) [native-inputs]: Replace node by node-lts,
instead of simply appending it.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 193ec390c1..8ad9dd4cc0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2794,7 +2794,7 @@ linux/libcurl_wrapper.h"
       #:configure-flags
       ;; Use the CMake ninja generator, otherwise the build fails (see:
       ;; https://bugreports.qt.io/browse/QTBUG-96897).
-      #~(list "-GNinja"                 ;
+      #~(list "-GNinja"
               ;; Manually add the NSS library prefix to the linker
               ;; search path, otherwise it fails to be linked (see:
               ;; https://bugreports.qt.io/browse/QTBUG-105053).
@@ -2875,9 +2875,9 @@ linux/libcurl_wrapper.h"
     (native-inputs
      (modify-inputs (package-native-inputs qtwebengine-5)
        (delete "python2" "python2-six")
+       (replace "node" node-lts)
        (append clang-14
                lld-as-ld-wrapper
-               node-lts
                python-wrapper
                python-html5lib)))
     (inputs