summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-01 12:48:08 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-01 13:00:01 +0200
commit279ed3efee9c71116d368163f805fe9494518687 (patch)
treecaf1df9cbae9625d7b4893e7afc74d1ca1f50163 /gnu/packages/qt.scm
parent53b7c9716e59555477ed39c066463f1bb4e0e03b (diff)
downloadguix-279ed3efee9c71116d368163f805fe9494518687.tar.gz
gnu: qtbase: Fix build with glibc >= 2.28.
* gnu/packages/patches/qtbase-glibc-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/qt.scm (qtbase)[source](patches): Use it.
[arguments]: Remove "--no-feature-renameat2" from #:configure-flags.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index f6eb2831fd..affba14e98 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -494,7 +494,8 @@ system, and the core design of Django is reused in Grantlee.")
               (base32
                "0ipv18ypbgpxhh49rfplqmflskmnhhwj1bjr5hrwi0jpvar4gl50"))
              ;; Use TZDIR to avoid depending on package "tzdata".
-             (patches (search-patches "qtbase-use-TZDIR.patch"))
+             (patches (search-patches "qtbase-use-TZDIR.patch"
+                                      "qtbase-glibc-compat.patch"))
              (modules '((guix build utils)))
              (snippet
                ;; corelib uses bundled harfbuzz, md4, md5, sha3
@@ -608,7 +609,6 @@ system, and the core design of Django is reused in Grantlee.")
                  ;; kernels that the glibc supports, including the RHEL6
                  ;; (2.6.32) and RHEL7 (3.10) kernels.
                  "-no-feature-getentropy"  ; requires Linux 3.17
-                 "-no-feature-renameat2"   ; requires Linux 3.16
 
                  ;; Do not build examples; if desired, these could go
                  ;; into a separate output, but for the time being, we