summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-09-20 13:04:25 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-13 13:53:40 +0200
commit868b1a025a5d34481cb22c8a653b61d7bc39684d (patch)
tree8150f07563cb30b7cf680b0fd30a95428e488b3c /gnu/packages/qt.scm
parent61cc757d5fdb5a08543796dd7c7e122e7c9d986e (diff)
downloadguix-868b1a025a5d34481cb22c8a653b61d7bc39684d.tar.gz
gnu: grantlee: Enable all tests.
* gnu/packages/qt.scm (grantlee)[arguments]
  <#:phases>'check-setup': New phase, set QT_QPA_PLATFORM=offscreen.
  <#:phases>'check': Remove phase.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2dd1d832bc..416ae7cf59 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -78,6 +78,7 @@
         (sha256
          (base32 "1lf9rkv0i0kd7fvpgg5l8jb87zw8dzcwd1liv6hji7g4wlpmfdiq"))))
     (native-inputs
+     ;; Optional: lcov and cccc, both are for code coverage
      `(("doxygen" ,doxygen)))
     (inputs
      `(("qtbase" ,qtbase)
@@ -86,10 +87,11 @@
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (replace 'check
-                  (lambda _
-                    (zero? (system* "ctest" ;; exclude 2 tests which require a display
-                                    "-E" "htmlbuildertest|plainmarkupbuildertest")))))))
+         (add-before 'check 'check-setup
+           (lambda _
+             ;; make Qt render "offscreen", required for tests
+             (setenv "QT_QPA_PLATFORM" "offscreen")
+             #t)))))
     (home-page "https://github.com/steveire/grantlee")
     (synopsis "Libraries for text templating with Qt")
     (description "Grantlee Templates can be used for theming and generation of