summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-07-22 13:47:39 -0400
committerLeo Famulari <leo@famulari.name>2020-07-23 18:14:53 -0400
commit0448bfe2d769998ba33c288a07738e13b02113a4 (patch)
tree7b67a89ae6f4ad6835ab24edee2d49ecace3c793 /gnu/packages/qt.scm
parente21793fb3ff8cac8499a135a04996ee4b8ccf083 (diff)
downloadguix-0448bfe2d769998ba33c288a07738e13b02113a4.tar.gz
gnu: Fix Krita.
Fixes <https://bugs.gnu.org/42476>.
Reported by linka on #guix.

* gnu/packages/patches/qtbase-fix-krita-deadlock.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/qt.scm (qtbase-for-krita): New variable.
* gnu/packages/kde.scm (krita)[inputs]: Replace qtbase with qtbase-for-krita.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0cb36427a0..1cbf7991ab 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -342,6 +342,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
 (define-public qtbase
   (package
     (name "qtbase")
+    ;; TODO Remove ((gnu packages kde) qtbase-for-krita) when upgrading qtbase.
     (version "5.14.2")
     (source (origin
              (method url-fetch)
@@ -608,6 +609,15 @@ developers using C++ or QML, a CSS & JavaScript like language.")
        (patches (append (origin-patches (package-source qtbase))
                         (search-patches "qtbase-absolute-runpath.patch")))))))
 
+(define-public qtbase-for-krita
+  (hidden-package
+    (package
+      (inherit qtbase)
+      (source (origin
+                (inherit (package-source qtbase))
+                (patches (append (origin-patches (package-source qtbase))
+                                 (search-patches "qtbase-fix-krita-deadlock.patch"))))))))
+
 (define-public qtsvg
   (package (inherit qtbase)
     (name "qtsvg")