summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-10-04 12:56:45 +0200
committerAndreas Enge <andreas@enge.fr>2015-10-04 23:04:26 +0200
commit14bcc1e1cd85d38db59b6b6089d63d429fb76b57 (patch)
tree2a95dc4445c42a6479a09f7489f32d0a3f49ea59 /gnu/packages/qt.scm
parent2b00a55064d2fbddb53209723cebc04710b33893 (diff)
downloadguix-14bcc1e1cd85d38db59b6b6089d63d429fb76b57.tar.gz
gnu: qt: Remove the sources of qtwebengine.
* gnu/packages/qt.scm (qt)[source]: Add snippet to remove the qtwebengine
  code, which was already not built anymore, and drop one patch used
  previously only for qtwebengine.
  [arguments]: Drop the configuration flag "-skip qtwebengine", since
  deleted modules cannot be skipped.
* gnu/packages/patches/qt5-runpath.patch: Delete file.
* gnu-system.am (dist_patch_DATA): Unregister patch.

Partially fixes <http://bugs.gnu.org/21288>.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm27
1 files changed, 10 insertions, 17 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index c2c3f9abcd..398e42c543 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -108,7 +108,16 @@ X11 (yet).")
              (sha256
                (base32
                  "1by2l8wxbqwvs7anb5ggmqhn2cfmhyw3a23bp1yyd240rdpa38ky"))
-             (patches (list (search-patch "qt5-runpath.patch")))))
+             (modules '((guix build utils)))
+             (snippet
+              ;; Remove qtwebengine, which relies on a bundled copy of
+              ;; chromium. Not only does it fail compilation in qt 5.5:
+              ;;    3rdparty/chromium/ui/gfx/codec/jpeg_codec.cc:362:10:
+              ;;    error: cannot convert ‘bool’ to ‘boolean’ in return
+              ;; it might also pose security problems.
+              ;; Alternatively, we could use the "-skip qtwebengine"
+              ;; configuration option.
+              '(delete-file-recursively "qtwebengine"))))
     (build-system gnu-build-system)
     (propagated-inputs
      `(("mesa" ,mesa)))
@@ -158,8 +167,6 @@ X11 (yet).")
      `(("bison" ,bison)
        ("flex" ,flex)
        ("gperf" ,gperf)
-       ;; Ninja is only needed for the disabled qtwebengine
-;;        ("ninja" ,ninja)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python" ,python-2)
@@ -175,14 +182,6 @@ X11 (yet).")
                 (("/bin/pwd") (which "pwd")))
               (substitute* "qtbase/src/corelib/global/global.pri"
                 (("/bin/ls") (which "ls")))
-              ;; commented out since qtwebengine is not built, but left in
-              ;; for reference
-;;               (substitute* "qtwebengine/src/3rdparty/chromium/build/common.gypi"
-;;                 (("/bin/echo") (which "echo")))
-;;               (substitute* "qtwebengine/src/3rdparty/chromium/third_party/\
-;; WebKit/Source/build/scripts/scripts.gypi"
-;;                 (("/usr/bin/gcc") (which "gcc")))
-;;               (setenv "NINJA_PATH" (which "ninja"))
               ;; do not pass "--enable-fast-install", which makes the
               ;; configure process fail
               (zero? (system*
@@ -196,12 +195,6 @@ X11 (yet).")
                       "-openssl-linked"
                       ;; explicitly link with dbus instead of dlopening it
                       "-dbus-linked"
-                      ;; drop chromium module (qtwebengine); it fails
-                      ;; compilation in qt 5.5:
-                      ;; 3rdparty/chromium/ui/gfx/codec/jpeg_codec.cc:362:10:
-                      ;; error: cannot convert ‘bool’ to ‘boolean’ in return
-                      ;; and might pose security problems.
-                      "-skip" "qtwebengine"
                       ;; drop special machine instructions not supported
                       ;; on all instances of the target
                       ,@(if (string-prefix? "x86_64"