summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-02-22 22:10:56 +1100
committerLeo Famulari <leo@famulari.name>2021-04-09 16:09:23 -0400
commit9360706294f69faf445016e206d5e8a4d595d430 (patch)
treebf87f731efca0f5cdbf4988bffd950edbd23086e /gnu/packages/qt.scm
parentc990604cb044dacf9c52fa33ec63b660329d4cb6 (diff)
downloadguix-9360706294f69faf445016e206d5e8a4d595d430.tar.gz
gnu: Add python-pyqt-builder.
* gnu/packages/qt.scm (python-pyqt-builder): New variable.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 83501b82ca..f9123ed08f 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2108,6 +2108,29 @@ itself.")
       ("qtwebchannel" ,qtwebchannel)
       ("qtwebengine" ,qtwebengine)))))
 
+(define-public python-pyqt-builder
+  (package
+   (name "python-pyqt-builder")
+   (version "1.9.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (pypi-uri "PyQt-builder" version))
+     (sha256
+      (base32
+       "0nh0054c54ji3sm6d268fccf0y5f613spswwgwqd3rnn816hnljl"))))
+   (build-system python-build-system)
+   (inputs
+    `(("python-sip" ,python-sip)))
+   (home-page "https://www.riverbankcomputing.com/static/Docs/PyQt-builder/")
+   (synopsis "PEP 517 compliant PyQt build system")
+   (description "PyQt-builder is a tool for generating Python bindings for C++
+libraries that use the Qt application framework.  The bindings are built on
+top of the PyQt bindings for Qt.  PyQt-builder is used to build PyQt itself.")
+   ;; Either version 2 or 3, but no other version. See the file
+   ;; 'pyqtbuild/builder.py' in the source distribution for more information.
+   (license (list license:gpl2 license:gpl3))))
+
 (define-public python-qtpy
   (package
     (name "python-qtpy")