summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-07 22:39:55 +0200
committerMarius Bakke <marius@gnu.org>2020-06-07 22:39:55 +0200
commitfd702f8e95c6e77c8658cf657002d2eb3dad29f9 (patch)
tree5079a06b73cc0a7aa56df7b76e49914596896bae /gnu/packages/qt.scm
parent8cbb32da7dfa53b15f2ecec7361e24961bb93bbc (diff)
downloadguix-fd702f8e95c6e77c8658cf657002d2eb3dad29f9.tar.gz
gnu: python-pyqt: Update to 5.14.2.
* gnu/packages/qt.scm (python-pyqt): Update to 5.14.2.
[source](uri): Add PyPI mirror.
[source](patches): Remove obsolete.
* gnu/packages/patches/pyqt-unbundled-qt.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2b3096a04e..17f7c8e8d0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1945,18 +1945,21 @@ module provides support functions to the automatically generated code.")
 (define-public python-pyqt
   (package
     (name "python-pyqt")
-    (version "5.12.3")
+    (version "5.14.2")
     (source
       (origin
         (method url-fetch)
-        (uri (string-append "https://www.riverbankcomputing.com/static/"
-                            "Downloads/PyQt5/" version "/PyQt5_gpl-"
-                            version ".tar.gz"))
+        ;; PyPI is the canonical distribution point of PyQt.  Older
+        ;; releases are available from the web site.
+        (uri (list (pypi-uri "PyQt5" version)
+                   (string-append "https://www.riverbankcomputing.com/static/"
+                                  "Downloads/PyQt5/" version "/PyQt5-"
+                                  version ".tar.gz")))
+        (file-name (string-append "PyQt5-"version ".tar.gz"))
         (sha256
          (base32
-          "041155bdzp57jy747p5d59740c55yy3241cy1x2lgcdsvqvzmc0d"))
+          "1c4y4qi1l540gd125ikj0al00k5pg65kmqaixcfbzslrsrphq8xx"))
        (patches (search-patches "pyqt-configure.patch"
-                                "pyqt-unbundled-qt.patch"
                                 "pyqt-public-sip.patch"))))
     (build-system gnu-build-system)
     (native-inputs