summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-08 09:25:50 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-08 12:06:33 +0200
commit3ed18c05e930ae0d4c3a72b588b3e24f805c7aef (patch)
treedb961f4c84d341325e3a6fe632e7bdd0a4b08458 /gnu/packages/qt.scm
parent4ccaaad45d58ebd6af47090b091cb7017f3536e7 (diff)
downloadguix-3ed18c05e930ae0d4c3a72b588b3e24f805c7aef.tar.gz
gnu: qtwebkit: Remove workaround for binutils bug.
This is a follow-up to de8e2a699c0219f5ea86f6bbfff4d5ee35104738.

* gnu/packages/qt.scm (qtwebkit)[arguments]: Remove custom 'build' phase.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index ff9a99c672..05037b034e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2733,19 +2733,7 @@ different kinds of sliders, and much more.")
                                ;; libraries and test executables in a
                                ;; reasonable amount of memory.
                                "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
-                               "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'build
-           ;; This is a workaround for the build failing with the error:
-           ;;   ld: error adding symbols: Malformed archive
-           ;; Increasing the maximum number of open file descriptors
-           ;; makes the build succeed.
-           (lambda* (#:key make-flags #:allow-other-keys)
-             (let ((cmd (format #f
-                                "ulimit -n 4096; make ~{~a~^ ~}"
-                                make-flags)))
-               (invoke "sh" "-c" cmd)))))))
+                               "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
     (home-page "https://www.webkit.org")
     (synopsis "Web browser engine and classes to render and interact with web
 content")