summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-18 00:06:03 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-31 21:55:46 -0400
commitd15258d991767ec83450fc6ebdb8ff2f60870501 (patch)
tree426a60af6e820269a890bf1149bdb69c663b119c /gnu/packages/qt.scm
parentd90031f799f6c56fa456dc7afe5bfdb59680f258 (diff)
downloadguix-d15258d991767ec83450fc6ebdb8ff2f60870501.tar.gz
gnu: qtwebsockets: Rename to qtwebsockets-5.
Automated via:

  git grep -l qtwebsockets | xargs sed 's/\bqtwebsockets\b/\0-5/g' -i
  git checkout NEWS
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d71b2991ad..d8838ec239 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1202,7 +1202,7 @@ integrate QML code with JavaScript and C++.")
     (description "The Qt Connectivity modules provides modules for interacting
 with Bluetooth and NFC.")))
 
-(define-public qtwebsockets
+(define-public qtwebsockets-5
   (package (inherit qtsvg-5)
     (name "qtwebsockets")
     (version "5.15.2")
@@ -1514,7 +1514,7 @@ and others.")))
               (base32
                "1h9y634phvvk557mhmf9z4lmxr41rl8x9mqy2lzp31mk8ffffzqj"))))
     (native-inputs
-     (list perl qtdeclarative-5 qtwebsockets))
+     (list perl qtdeclarative-5 qtwebsockets-5))
     (inputs (list qtbase-5))
     (synopsis "Web communication library for Qt")
     (description "The Qt WebChannel module enables peer-to-peer communication
@@ -1542,7 +1542,7 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
                #t))))))
     (native-inputs '())
     (inputs
-     (list mesa qtbase-5 qtdeclarative-5 qtwebsockets zlib))
+     (list mesa qtbase-5 qtdeclarative-5 qtwebsockets-5 zlib))
     (synopsis "QPA plugin for running an application via a browser using
 streamed WebGL commands")
     (description "Qt back end that uses WebGL for rendering. It allows Qt
@@ -2468,7 +2468,7 @@ module provides support functions to the automatically generated code.")
        ("qttools" ,qttools)
        ("qtwebchannel" ,qtwebchannel)
        ("qtwebkit" ,qtwebkit)
-       ("qtwebsockets" ,qtwebsockets)
+       ("qtwebsockets-5" ,qtwebsockets-5)
        ("qtx11extras" ,qtx11extras)
        ("qtxmlpatterns" ,qtxmlpatterns)))
     (arguments
@@ -3283,7 +3283,7 @@ color-related widgets.")
            qtsvg-5
            qtwebchannel
            qtwebengine
-           qtwebsockets
+           qtwebsockets-5
            qtx11extras
            qtxmlpatterns))
     (propagated-inputs
@@ -3333,7 +3333,7 @@ color-related widgets.")
                                 "qttools"
                                 "qtwebchannel"
                                 "qtwebengine"
-                                "qtwebsockets"
+                                "qtwebsockets-5"
                                 "qtx11extras"
                                 "qtxmlpatterns"))))
                (substitute* "cmake/Macros/PySideModules.cmake"