summary refs log tree commit diff
path: root/gnu/packages/racket.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-02-27 16:28:57 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-03-04 23:36:48 +0100
commit0ff69fa1dd944706ad3835593cbea0af3fad3d17 (patch)
treeb6f336c67cf4d08770b6864f554585fb75b943da /gnu/packages/racket.scm
parentb5f654b238dd3dec43b0ee9e08b78981cf8de981 (diff)
downloadguix-0ff69fa1dd944706ad3835593cbea0af3fad3d17.tar.gz
gnu: Use license prefix in (gnu packages racket).
* gnu/packages/racket.scm (racket-minimal, racket-minimal-bc-3m)
(racket-bootstrap-chez-bootfiles): Use license prefix.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/racket.scm')
-rw-r--r--gnu/packages/racket.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index d0a5ca494b..ec9e836a4c 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -21,8 +21,6 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages racket)
-  #:use-module ((guix licenses)
-                #:select (asl2.0 expat lgpl3+))
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -47,7 +45,8 @@
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tls)
-  #:use-module (gnu packages xorg))
+  #:use-module (gnu packages xorg)
+  #:use-module ((guix licenses) #:prefix license:))
 
 ;; Commentary:
 ;;
@@ -254,7 +253,7 @@ use @command{raco pkg} to install more.  Bundled packages, such as the
 DrRacket IDE, are not included.")
     ;; https://download.racket-lang.org/license.html
     ;; The LGPL components are only used by Racket BC.
-    (license (list asl2.0 expat))))
+    (license (list license:asl2.0 license:expat))))
 
 
 (define-public racket-minimal-bc-3m
@@ -295,7 +294,7 @@ This package is the normal implementation of Racket BC with a precise garbage
 collector, 3M (``Moving Memory Manager'').")
      ;; https://download.racket-lang.org/license.html
      ;; The LGPL components are only used by Racket BC.
-     (license (list lgpl3+ asl2.0 expat)))))
+     (license (list license:lgpl3+ license:asl2.0 license:expat)))))
 
 
 (define-public racket-minimal-bc-cgc
@@ -372,7 +371,7 @@ long as using an existing Chez Scheme, but @code{cs-bootstrap} supports Racket
 Note that the generated bootfiles are specific to Racket's fork of Chez
 Scheme, and @code{cs-bootstrap} does not currently support building upstream
 Chez Scheme.")
-     (license (list asl2.0)))))
+     (license (list license:asl2.0)))))
 
 
 (define %installer-mirrors