summary refs log tree commit diff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-12-14 17:32:42 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-12-14 18:23:57 +0100
commitd86c6cbd7b60d7e8cd0e30f8bb654d07b76e592b (patch)
treefe1438c1f2fdbc9ecca266aad759efad781e6eee /gnu/packages/radio.scm
parentd94f7a7b5363c71bc9dbeaf6fff17b3a94c9fb18 (diff)
downloadguix-d86c6cbd7b60d7e8cd0e30f8bb654d07b76e592b.tar.gz
gnu: soapyhackrf: Update to 0.3.4-1.6c0c33f.
* gnu/packages/radio.scm (soapyhackrf): Update to 0.3.4-1.6c0c33f.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm47
1 files changed, 25 insertions, 22 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index ecca65391c..51f9240a07 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -427,28 +427,31 @@ controls for certain tuners which may be paired with an audio device.")
       (license license:expat))))
 
 (define-public soapyhackrf
-  (package
-    (name "soapyhackrf")
-    (version "0.3.4")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/pothosware/SoapyHackRF")
-             (commit (string-append "soapy-hackrf-" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0wnnsm3c4ivwcbs1b68svbyds13aajws9mqk2xjc2pqgj0fdhcvz"))))
-    (build-system cmake-build-system)
-    (inputs
-     (list hackrf soapysdr))
-    (arguments
-     `(#:tests? #f))  ; No test suite
-    (home-page "https://github.com/pothosware/SoapyHackRF/wiki")
-    (synopsis "SoapySDR HackRF module")
-    (description
-     "This package provides HackRF devices support to the SoapySDR library.")
-    (license license:expat)))
+  ;; Some fixes are not yet in a tagged release.
+  (let ((commit "6c0c33f0aa44c3080674e6bca0273184d3e9eb44")
+        (revision "1"))
+    (package
+      (name "soapyhackrf")
+      (version (git-version "0.3.4" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/pothosware/SoapyHackRF")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1khplrp6iphdclj1wrybxs7pw42rf9112fhfhw7x2fvds8yiswm7"))))
+      (build-system cmake-build-system)
+      (inputs
+       (list hackrf soapysdr))
+      (arguments
+       `(#:tests? #f))  ; No test suite
+      (home-page "https://github.com/pothosware/SoapyHackRF/wiki")
+      (synopsis "SoapySDR HackRF module")
+      (description
+       "This package provides HackRF devices support to the SoapySDR library.")
+      (license license:expat))))
 
 (define-public soapyrtlsdr
   (package