summary refs log tree commit diff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-01-27 21:24:33 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-01-27 21:24:33 +0100
commit3ee633feb2dc873df0217c36b89dbde0b4fbb0cc (patch)
treee04e26df1b8bb6fd8a8307757f8c89270942c0cc /gnu/packages/radio.scm
parentff14bc60e56fb0c6636da1da9a850b7b04abb367 (diff)
downloadguix-3ee633feb2dc873df0217c36b89dbde0b4fbb0cc.tar.gz
gnu: Add kockmorse.
* gnu/packages/radio.scm (kockmorse): New variable.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 1e02e2f33e..3cc5b73575 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1583,6 +1583,32 @@ programs using the library: cw, cwgen, cwcp and xcwcp.  The programs are
 intended for people who want to learn receiving and sending morse code.")
     (license license:gpl2+)))
 
+(define-public kockmorse
+  (package
+    (name "kochmorse")
+    (version "3.5.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/hmatuschek/kochmorse")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1s1aj223n57rpc95rih98z08xnyhq2zp02byzrc3f7s01fv3nj0l"))))
+    (build-system qt-build-system)
+    (native-inputs
+     (list qttools))
+    (inputs
+     (list qtbase-5 qtmultimedia))
+    (arguments
+     `(#:tests? #f)) ; No test suite
+    (home-page "https://dm3mat.darc.de/kochmorse/")
+    (synopsis "Morse code tutor")
+    (description
+     "KochMorse is a simple morse-code tutor using the Koch method.")
+    (license license:gpl2+)))
+
 (define-public gnuais
   (package
     (name "gnuais")