summary refs log tree commit diff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-03-14 14:16:50 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-03-14 14:23:50 +0100
commitbcc13ee8a19b09ae880ebb18e5a0cc75a9219a14 (patch)
tree9953682f8d7c2398e6b5b9c80e3909546fc6214e /gnu/packages/radio.scm
parentc0ca63b4da8113a23aca618144136d68dcc7bc58 (diff)
downloadguix-bcc13ee8a19b09ae880ebb18e5a0cc75a9219a14.tar.gz
gnu: rtl-sdr: Update to 0.6.0.1-5e73f90.
* gnu/packages/radio.scm (rtl-sdr): Update to 0.6.0.1-5e73f90.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm73
1 files changed, 37 insertions, 36 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index ba994ad1ef..477b094d75 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -171,41 +171,42 @@ mathematical operations, and much more.")
     (license license:expat)))
 
 (define-public rtl-sdr
-  (package
-    (name "rtl-sdr")
-    (version "0.6.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://git.osmocom.org/rtl-sdr/")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "0lmvsnb4xw4hmz6zs0z5ilsah5hjz29g1s0050n59fllskqr3b8k"))))
-    (build-system cmake-build-system)
-    (inputs
-     (list libusb))
-    (native-inputs
-     (list pkg-config))
-    (arguments
-     `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON"
-                           "-DINSTALL_UDEV_RULES=ON")
-       #:tests? #f ; No tests
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-paths
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "CMakeLists.txt"
-               (("DESTINATION \"/etc/udev/")
-                (string-append "DESTINATION \""
-                               (assoc-ref outputs "out")
-                               "/lib/udev/")))
-             #t)))))
-    (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr")
-    (synopsis "Software defined radio driver for Realtek RTL2832U")
-    (description "DVB-T dongles based on the Realtek RTL2832U can be used as a
+  ;; No tagged release since 2018
+  (let ((commit "5e73f90f1d85d8db2e583f3dbf1cff052d71d59b")
+        (revision "1"))
+    (package
+      (name "rtl-sdr")
+      (version (git-version "0.6.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://git.osmocom.org/rtl-sdr/")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "106fwzyr7cba952f3p3wm3hdqzm9zvm0v3gcz4aks2n7fnvrgrvn"))))
+      (build-system cmake-build-system)
+      (inputs
+       (list libusb))
+      (native-inputs
+       (list pkg-config))
+      (arguments
+       `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON"
+                             "-DINSTALL_UDEV_RULES=ON")
+         #:tests? #f ; No tests
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'fix-paths
+             (lambda* (#:key outputs #:allow-other-keys)
+               (substitute* "CMakeLists.txt"
+                 (("DESTINATION \"/etc/udev/")
+                  (string-append "DESTINATION \""
+                                 (assoc-ref outputs "out")
+                                 "/lib/udev/"))))))))
+      (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr")
+      (synopsis "Software defined radio driver for Realtek RTL2832U")
+      (description "DVB-T dongles based on the Realtek RTL2832U can be used as a
 cheap software defined radio, since the chip allows transferring the raw I/Q
 samples to the host.  @code{rtl-sdr} provides drivers for this purpose.
 
@@ -220,7 +221,7 @@ system configuration:
 
 To install the rtl-sdr udev rules, you must extend 'udev-service-type' with
 this package.  E.g.: @code{(udev-rules-service 'rtl-sdr rtl-sdr)}")
-    (license license:gpl2+)))
+      (license license:gpl2+))))
 
 (define-public airspyhf
   (package