summary refs log tree commit diff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-09 14:44:48 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-09 14:44:48 +0200
commitda3be3ff4f6d8b643ed9bdf6834df366b1bcea44 (patch)
tree913ff6010447b6a31dfbe4be6eccc06b11fd83cf /gnu/packages/radio.scm
parentf5fe0082abe4547f3fb9f29d8351473cfb3a387b (diff)
parent4980630d1e3e6f9a6dc05438c7593a727207d9a0 (diff)
downloadguix-da3be3ff4f6d8b643ed9bdf6834df366b1bcea44.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm72
1 files changed, 67 insertions, 5 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 9c6db4d93f..ac81d337a3 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2018, 2019, 2020, 2022 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2019, 2020 Christopher Howard <christopher@librehacker.com>
 ;;; Copyright © 2019, 2020 Evan Straw <evan.straw99@gmail.com>
 ;;; Copyright © 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
@@ -921,7 +921,7 @@ using GNU Radio and the Qt GUI toolkit.")
 (define-public fldigi
   (package
     (name "fldigi")
-    (version "4.1.20")
+    (version "4.1.22")
     (source
      (origin
        (method git-fetch)
@@ -930,7 +930,7 @@ using GNU Radio and the Qt GUI toolkit.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0y43241s3p8qzn7x6x28v5v2bf934riznj14bb7m6k6vgd849qzl"))))
+        (base32 "1n1ljqsqar9s8yh8hn9yc1clabkhv4jidym3ibg25yb5svckscli"))))
     (build-system gnu-build-system)
     (native-inputs
      (list autoconf automake gettext-minimal pkg-config))
@@ -960,7 +960,7 @@ hardware.")
 (define-public flrig
   (package
     (name "flrig")
-    (version "1.4.04")
+    (version "1.4.05")
     (source
      (origin
        (method git-fetch)
@@ -969,7 +969,7 @@ hardware.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "06alzln46x08110v1ghasphr2mmznzk0x5h59vl9g2w1z12i9zsm"))))
+        (base32 "0pgkfzxqr2ybpbnf1y9nsr25k0zimdwr98mpvd7nazrv5l0y8kci"))))
     (build-system gnu-build-system)
     (native-inputs
      (list autoconf automake pkg-config))
@@ -2424,6 +2424,68 @@ vendor-neutral SDR support library instead, intended to support a wider range
 of devices than RTL-SDR.")
       (license license:gpl2+))))
 
+(define-public urh
+  (package
+    (name "urh")
+    (version "2.9.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jopohl/urh")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "17r9fkw0icph7fayibp6qbdh4nxi8wy3mmd3djmh0c2jr8yz5fsf"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list python-cython
+           python-pytest
+           xorg-server-for-tests))
+    (inputs
+     (list gnuradio
+           gr-osmosdr
+           hackrf
+           python-numpy
+           python-psutil
+           python-pyaudio
+           python-pyqt
+           rtl-sdr))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'configure-compiler
+           (lambda _
+             ;; Use gcc as compiler
+             (substitute* "src/urh/dev/native/ExtensionHelper.py"
+               (("compiler = ccompiler\\.new_compiler\\(\\)\n" all)
+                (string-append
+                 all "    compiler.set_executables(compiler='gcc',"
+                 " compiler_so='gcc', linker_exe='gcc', linker_so='gcc -shared')\n")))))
+         (add-after 'unpack 'disable-some-tests
+           (lambda _
+             (for-each delete-file
+                       '(;; FIXME: This test causes a segmentation fault
+                         "tests/test_send_recv_dialog_gui.py"))))
+         (add-after 'build 'build-cythonext
+           (lambda _
+             (invoke "python" "src/urh/cythonext/build.py")))
+         (replace 'check
+           (lambda* (#:key inputs tests? #:allow-other-keys)
+             (when tests?
+               (setenv "HOME" "/tmp")
+               (system (string-append (search-input-file inputs "/bin/Xvfb")
+                                     " :1 &"))
+               (setenv "DISPLAY" ":1")
+               (invoke "pytest")))))))
+    (home-page "https://github.com/jopohl/urh")
+    (synopsis "Wireless protocol investigation program")
+    (description
+     "The Universal Radio Hacker (URH) is a complete suite for wireless
+protocol investigation with native support for many common Software Defined
+Radios.")
+    (license license:gpl3+)))
+
 (define-public gnss-sdr
   (package
     (name "gnss-sdr")