summary refs log tree commit diff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-05-03 17:53:10 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-07 18:16:59 +0200
commit82b72a7d795f308ed35b5d7018bb30a09c92c31a (patch)
tree9ece8193bdf80a00a195555e7e8b0426dda225c4 /gnu/packages/radio.scm
parent1bd9f785b616612fd71f8b8941a0c17d18bdfa06 (diff)
downloadguix-82b72a7d795f308ed35b5d7018bb30a09c92c31a.tar.gz
gnu: Add cm256cc.
* gnu/packages/radio.scm (cm256cc): New variable.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 73f0d03e01..aebdf58cb4 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1638,3 +1638,33 @@ program that can be used to build simple signal processing flow graphs.")
      "SerialDV is a minimal interface to encode and decode audio with AMBE3000
 based devices in packet mode over a serial link.")
     (license license:gpl3+)))
+
+(define-public cm256cc
+  (package
+    (name "cm256cc")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/f4exb/cm256cc")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1n9v7g6d370263bgqrjv38s9aq5953rzy7jvd8i30xq6aram9djg"))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; Disable some SIMD features for reproducibility.
+     `(#:configure-flags '("-DENABLE_DISTRIBUTION=1")
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "./cm256_test")))))))
+    (home-page "https://github.com/f4exb/cm256cc")
+    (synopsis "Cauchy MDS Block Erasure Codec")
+    (description
+     "This is a C++ library implementing fast GF(256) Cauchy MDS Block Erasure
+Codec.")
+    (license license:gpl3+)))