summary refs log tree commit diff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-16 14:49:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-19 13:12:28 +0200
commitee10850d14ba69810bf9b88babbaec6256ddaaa8 (patch)
tree3661ae066df24d6457f4ea7a998b3d17e741e6be /gnu/packages/rdf.scm
parente54faebaebefe243747787455ef92945050dfe66 (diff)
downloadguix-ee10850d14ba69810bf9b88babbaec6256ddaaa8.tar.gz
gnu: serd: Update to 0.30.16.
* gnu/packages/rdf.scm (serd): Update to 0.30.16.
[build-system]: Use meson-build-system.
[arguments]: Use G-expression.
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 13e62baa84..d7a0f2ff0b 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -33,6 +33,7 @@
   #:use-module (guix download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
   #:use-module (guix build-system waf)
   #:use-module (gnu packages)
@@ -278,26 +279,24 @@ and triple stores.")
 (define-public serd
   (package
     (name "serd")
-    (version "0.30.8")
+    (version "0.30.16")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.drobilla.net/serd-"
-                                 version ".tar.bz2"))
+                                 version ".tar.xz"))
              (sha256
               (base32
-               "11zs53yx40mv62vxsl15mvdh7s17y5v6lgcgahdvzxgnan7w8bk7"))))
-    (build-system waf-build-system)
+               "0ilimkczibiwwvc12i14b8zi6ng42hjf9j907g8dik8rlmnlh3zm"))))
+    (build-system meson-build-system)
     (arguments
-     `(#:tests? #f                      ; no check target
-       #:phases
-       (modify-phases %standard-phases
-         (add-before
-          'configure 'set-ldflags
-          (lambda* (#:key outputs #:allow-other-keys)
-            (setenv "LDFLAGS"
-                    (string-append "-Wl,-rpath="
-                                   (assoc-ref outputs "out") "/lib"))
-            #t)))))
+     (list
+      #:tests? #f                       ; no check target
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'configure 'set-ldflags
+            (lambda _
+              (setenv "LDFLAGS"
+                      (string-append "-Wl,-rpath=" #$output "/lib")))))))
     (home-page "https://drobilla.net/software/serd/")
     (synopsis "Library for RDF syntax supporting Turtle and NTriples")
     (description