summary refs log tree commit diff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 13:36:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:36:14 +0100
commit4255818d1c3993988b3351d57db6e057a867f549 (patch)
treef1fb3c11cbb1e6be83f342f1cdf6f9f6cef67922 /gnu/packages/rdf.scm
parent48b11025b734af39023e780ee7f15522dca1c7ea (diff)
downloadguix-4255818d1c3993988b3351d57db6e057a867f549.tar.gz
gnu: python-rdflib: Use PYPI-URI.
* gnu/packages/rdf.scm (python-rdflib)[source]: Use PYPI-URI.
[arguments]: Use INVOKE in commented build phase.
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 7fd893c374..4a3efd8d3f 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -304,13 +304,10 @@ ideal (e.g. in LV2 implementations or embedded applications).")
     (source
       (origin
         (method url-fetch)
-        (uri (string-append
-              "https://pypi.python.org/packages/source/r/rdflib/rdflib-"
-              version
-              ".tar.gz"))
+        (uri (pypi-uri "rdflib" version))
         (sha256
-          (base32
-            "0398c714znnhaa2x7v51b269hk20iz073knq2mvmqp2ma92z27fs"))))
+         (base32
+          "0398c714znnhaa2x7v51b269hk20iz073knq2mvmqp2ma92z27fs"))))
     (build-system python-build-system)
     (arguments
      '(;; FIXME: Three test failures. Should be fixed next release.
@@ -321,7 +318,7 @@ ideal (e.g. in LV2 implementations or embedded applications).")
        ;;     (lambda _
        ;;       ;; Run tests from the build directory so python3 only
        ;;       ;; sees the installed 2to3 version.
-       ;;       (zero? (system* "nosetests" "--where=./build/src")))))))
+       ;;       (invoke "nosetests" "--where=./build/src"))))))
     (native-inputs
      `(("python-nose" ,python-nose)))
     (propagated-inputs
@@ -329,13 +326,12 @@ ideal (e.g. in LV2 implementations or embedded applications).")
         ("python-isodate" ,python-isodate)
         ("python-pyparsing" ,python-pyparsing)))
     (home-page "https://github.com/RDFLib/rdflib")
-    (synopsis
-      "Python RDF library")
+    (synopsis "Python RDF library")
     (description
       "RDFLib is a Python library for working with RDF, a simple yet
 powerful language for representing information.")
     (license (non-copyleft "file://LICENSE"
-                        "See LICENSE in the distribution."))))
+                           "See LICENSE in the distribution."))))
 
 (define-public python2-rdflib
   (package-with-python2 python-rdflib))