summary refs log tree commit diff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-02-27 11:53:06 -0500
committerMark H Weaver <mhw@netris.org>2015-02-28 09:49:01 -0500
commit722ec722441a755e18fbc696d23441427dfb26af (patch)
tree8d429f0ec1b30d692ab24bc07838e47b4cb33ab8 /gnu/packages/rdf.scm
parentdd0a8ef15f903422c6b020e7d793986427add927 (diff)
downloadguix-722ec722441a755e18fbc696d23441427dfb26af.tar.gz
gnu: Move autoconf-style phases after the unpack phase.
* gnu/packages/audio.scm (soundtouch)[arguments]: Move 'bootstrap'
  after 'unpack'.  Remove custom /usr/bin/file patching, which will
  now be handled by the 'patch-usr-bin-file' phase.
* gnu/packages/emacs.scm (emacs-w3m)[arguments]: Rename 'pre-configure'
  phase to 'autoconf' and move it after 'unpack'.
* gnu/packages/fontutils.scm (libuninameslist)[arguments]: Move 'bootstrap'
  phase after 'unpack'.
* gnu/packages/libevent.scm (libuv)[arguments]: Move 'autogen' phase after
  'unpack'.  Run "sh autogen.sh" instead of "./autogen.sh".
* gnu/packages/linux.scm (bridge-utils)[arguments]: Move 'bootstrap' phase
  after 'unpack'.
* gnu/packages/mail.scm (libetpan)[arguments]: Move 'autogen' phase after
  'unpack'.  Run "sh autogen.sh" instead of "./autogen.sh".  Setenv
  "NOCONFIGURE" before running autogen.sh.
* gnu/packages/package-management.scm (guix-devel)[arguments]: Move
  'bootstrap' phase after 'unpack'.  Run "sh autogen.sh" instead of
  "./autogen.sh".
* gnu/packages/rdf.scm (lrdf)[arguments]: Move 'autoreconf' phase after
  'remove-out-of-tree-references' phase.
* gnu/packages/tor.scm (privoxy)[arguments]: Move 'autoconf' phase after
  'unpack'.
* gnu/packages/web.scm (libpsl)[arguments]: Move 'bootstrap' phase after
  'unpack'.  Run "sh autogen.sh" instead of "./autogen.sh".  Remove
  'fix-autogen-shebang' phase.
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 5102ebe921..8edc2f46fc 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -140,9 +140,9 @@ Java Lucene text search engine API to C++.")
                    (substitute* "examples/Makefile.am"
                      (("instances_test remove_test") "instances_test")
                      (("\\$\\(TESTS\\) remove_test") "$(TESTS)")))
-                 (alist-cons-before
-                  'configure 'autoreconf
-                  (lambda* (#:key inputs #:allow-other-keys)
+                 (alist-cons-after
+                  'remove-out-of-tree-references 'autoreconf
+                  (lambda _
                     (zero? (system* "autoreconf" "-vfi")))
                   %standard-phases))))
     (inputs