summary refs log tree commit diff
path: root/gnu/packages/regex.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-08-17 16:10:15 +0100
committerAlex Kost <alezost@gmail.com>2016-09-12 16:38:03 +0300
commitac8a6428867086b1091d8a1f4b21b1e321531256 (patch)
tree6589e4acc4774709b1baade0a29882af4a7da0d3 /gnu/packages/regex.scm
parentf32ffa04ba14a3dc6cc6e30e71bcfccf0ddf50e2 (diff)
downloadguix-ac8a6428867086b1091d8a1f4b21b1e321531256.tar.gz
gnu: tre: Move to (gnu packages regex).
* gnu/packages/tre.scm: Remove.  Move 'tre' to...
* gnu/packages/regex.scm (tre): ... here.  New variable.
* gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.

Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages/regex.scm')
-rw-r--r--gnu/packages/regex.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/regex.scm b/gnu/packages/regex.scm
index cea9db8379..e685a17d28 100644
--- a/gnu/packages/regex.scm
+++ b/gnu/packages/regex.scm
@@ -1,4 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 John Darrington
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -55,3 +57,33 @@
 backtracking regular expression engines like those used in PCRE, Perl and
 Python.  It is a C++ library.")
      (license license:bsd-3)))
+
+(define-public tre
+  (package
+    (name "tre")
+    (version "0.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://laurikari.net/tre/"
+                                  name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0n36cgqys59r2gmb7jzbqiwsy790v8nbxk82d2n2saz0rp145ild"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases (alist-cons-before
+                 'check 'install-locales
+                 (lambda _
+                   ;; The tests require the availability of the
+                   ;; 'en_US.ISO-8859-1' locale.
+                   (setenv "LOCPATH" (getcwd))
+                   (zero? (system* "localedef" "--no-archive"
+                                   "--prefix" (getcwd) "-i" "en_US"
+                                   "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))
+                 %standard-phases)))
+    (synopsis "Approximate regex matching library and agrep utility")
+    (description "Superset of the POSIX regex API, enabling approximate
+matching.  Also ships a version of the agrep utility which behaves similar to
+grep but features inexact matching.")
+    (home-page "http://laurikari.net/tre")
+    (license license:bsd-2)))