summary refs log tree commit diff
path: root/gnu/packages/regex.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-08-14 20:16:01 +0100
committerLeo Famulari <leo@famulari.name>2016-08-18 16:37:23 -0400
commitdc253bf0a56e650d58b5f9edfcbf344d1c637c00 (patch)
treeab1f54b6725c43514d14b8eaa34647093b0f26ce /gnu/packages/regex.scm
parent5f0ff6a9e930ab20ce74ff77a82f6f7fab8ffbd0 (diff)
downloadguix-dc253bf0a56e650d58b5f9edfcbf344d1c637c00.tar.gz
gnu: Add re2.
* gnu/packages/regex.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/regex.scm')
-rw-r--r--gnu/packages/regex.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/regex.scm b/gnu/packages/regex.scm
new file mode 100644
index 0000000000..cea9db8379
--- /dev/null
+++ b/gnu/packages/regex.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages regex)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public re2
+   (package
+     (name "re2")
+     (version "2016-08-01")
+     (source (origin
+               (method url-fetch)
+               (uri
+                (string-append
+                 "https://github.com/google/re2/archive/"
+                 version ".tar.gz"))
+               (file-name (string-append name "-" version ".tar.gz"))
+               (sha256
+                (base32
+                 "06pfm3xi5irrrij85m0c46rsn9jyg1rc2r431wi2knhjvbw9f0bx"))))
+     (build-system gnu-build-system)
+     (arguments
+      `(#:test-target "test"
+        ;; There is no configure step, but the Makefile respects a prefix.
+        #:make-flags (list (string-append "prefix=" %output))
+        #:phases
+        (modify-phases %standard-phases
+          (delete 'configure)
+          (add-after 'install 'delete-static-library
+            (lambda* (#:key outputs #:allow-other-keys)
+              ;; No make target for shared-only; delete the static version.
+              (delete-file (string-append (assoc-ref outputs "out")
+                                          "/lib/libre2.a")))))))
+     (home-page "https://github.com/google/re2")
+     (synopsis "Fast, safe, thread-friendly regular expression engine")
+     (description "RE2 is a fast, safe, thread-friendly alternative to
+backtracking regular expression engines like those used in PCRE, Perl and
+Python.  It is a C++ library.")
+     (license license:bsd-3)))