summary refs log tree commit diff
path: root/gnu/packages/rocm.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-08-06 08:24:44 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-08-08 16:47:55 +0200
commita85eff8171966ecba5b6c5bb66d7ff1f9fda7fb7 (patch)
treea39691633f30e86d184dc1710cbfe2076d8ea1e0 /gnu/packages/rocm.scm
parentdc5755c41133bb303f775e2143a0919240f4562c (diff)
downloadguix-a85eff8171966ecba5b6c5bb66d7ff1f9fda7fb7.tar.gz
gnu: Add rocr-runtime.
* gnu/packages/rocm.scm (rocr-runtime): New variable.
Diffstat (limited to 'gnu/packages/rocm.scm')
-rw-r--r--gnu/packages/rocm.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/rocm.scm b/gnu/packages/rocm.scm
index 4ed4d95d60..2155ea2e49 100644
--- a/gnu/packages/rocm.scm
+++ b/gnu/packages/rocm.scm
@@ -169,3 +169,42 @@ AMDGPU code objects.")
     (description "User-mode API interfaces used to interact with the ROCk
 driver.")
     (license license:ncsa)))
+
+(define-public rocr-runtime
+  (package
+    (name "rocr-runtime")
+    (version %rocm-version)
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/RadeonOpenCompute/ROCR-Runtime.git")
+                    (commit (string-append "rocm-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0jqfqf5ymwlbpac065bhigmkgsk7mbyimdgvca7ymn38wpf80ka7"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags
+       `(,(string-append
+           "-DBITCODE_DIR="
+           (assoc-ref %build-inputs "rocm-device-libs")
+           "/amdgcn/bitcode/"))
+       #:tests? #f ; No tests.
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _
+             (chdir "src"))))))
+    (inputs
+     `(("libelf" ,libelf)
+       ("numactl" ,numactl)
+       ("llvm" ,llvm-for-rocm)
+       ("roct-thunk-interface" ,roct-thunk-interface)
+       ("rocm-device-libs" ,rocm-device-libs))) ; For bitcode.
+    (native-inputs `(("xxd" ,xxd)))
+    (home-page "https://github.com/RadeonOpenCompute/ROCR-Runtime")
+    (synopsis "ROCm Platform Runtime")
+    (description "User-mode API interfaces and libraries necessary for host
+applications to launch compute kernels to available HSA ROCm kernel agents.")
+    (license license:ncsa)))