summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMikhail Kirillov <w96k.ru@gmail.com>2019-07-03 20:10:27 +0300
committerLudovic Courtès <ludo@gnu.org>2019-07-04 12:31:44 +0200
commitfc4f7c45cfcb20af1cbec96f4e5ce3097af1f9c8 (patch)
tree88f1c484e18db3ccd1192aa59b9f10712b1af411 /gnu/packages/ruby.scm
parent872da48eab09e23529137fa7751c286afcc1241d (diff)
downloadguix-fc4f7c45cfcb20af1cbec96f4e5ce3097af1f9c8.tar.gz
gnu: Add ruby-backport.
* gnu/packages/ruby.scm (ruby-backport): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 49e0b9fe73..5f613cfe60 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -14,6 +14,7 @@
 ;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Mikhail Kirillov <w96k.ru@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8725,3 +8726,32 @@ app to deliver to smtp://127.0.0.1:1025 instead of your default SMTP server,
 then check out http://127.0.0.1:1080 to see the mail.")
     (home-page "https://mailcatcher.me")
     (license license:expat)))
+
+(define-public ruby-backport
+  (package
+    (name "ruby-backport")
+    (version "1.1.1")
+    (source
+     (origin
+       ;; The gem does not include test code, so fetch from the Git repository
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/castwide/backport.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0ii3y1wx1n48nd2mhlv0v61b2m21h7dg30if9vc2idza7k4afyw8"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:test-target "spec"))
+    (native-inputs
+     `(("bundler" ,bundler)
+       ("ruby-rspec" ,ruby-rspec)))
+    (inputs
+     `(("ruby-simplecov" ,ruby-simplecov)))
+    (synopsis "Pure Ruby library for event-driven IO")
+    (description
+     "This package provides a pure Ruby library for event-driven IO.")
+    (home-page "https://github.com/castwide/backport")
+    (license license:expat)))