summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-28 08:54:42 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:26:00 +0100
commit256e18af346882d10ae3f3eb86de4fb5a689551e (patch)
tree78e6ed111e797e4a2cacf781703ec2a83d92d527 /gnu/packages/ruby.scm
parentea9a1e0289d368646c809fd7ee5c471dcb1ec629 (diff)
downloadguix-256e18af346882d10ae3f3eb86de4fb5a689551e.tar.gz
gnu: ruby-maxitest: Update to 5.1.0.
* gnu/packages/ruby.scm (ruby-maxitest): Update to 5.1.0.
[arguments]: Update style.
[native-inputs]: Remove ruby-byebug.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 33443038c3..4f202249f2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5186,7 +5186,7 @@ Ruby, but can be used for all programs.")
 (define-public ruby-maxitest
   (package
     (name "ruby-maxitest")
-    (version "4.4.1")
+    (version "5.1.0")
     (home-page "https://github.com/grosser/maxitest")
     (source (origin
               ;; Pull from git because the gem does not contain tests.
@@ -5197,31 +5197,32 @@ Ruby, but can be used for all programs.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0l646lgrgsfgg9qh05b8a3jd43kgrmr6xzbdvyspmdlhchk1qszg"))))
+                "0qj410krfm497ggmf71xpnabbb6814y0585by4nlzyjvg9hpgg3m"))))
     (build-system ruby-build-system)
     (arguments
-     '(#:test-target "default"
-       #:phases (modify-phases %standard-phases
-                  (replace 'replace-git-ls-files
-                    (lambda _
-                      (substitute* "maxitest.gemspec"
-                        (("`git ls-files lib/ bin/ MIT-LICENSE Readme.md`")
-                         "`find lib/ bin/ MIT-LICENSE Readme.md -type f | sort`"))))
-                  (add-before 'check 'remove-version-constraints
-                    (lambda _
-                      ;; Don't use specific versions of dependencies, instead
-                      ;; take whatever is available in Guix.
-                      (delete-file "Gemfile.lock")))
-                  (add-before 'check 'add-mtest-on-PATH
-                    (lambda _
-                      ;; Tests use 'mtest' which is not automatically added on
-                      ;; PATH.
-                      (setenv "PATH" (string-append (getcwd) "/bin:"
-                                                    (getenv "PATH"))))))))
+     (list
+      #:test-target "default"
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'replace-git-ls-files
+            (lambda _
+              (substitute* "maxitest.gemspec"
+                (("`git ls-files lib/ bin/ MIT-LICENSE Readme.md`")
+                 "`find lib/ bin/ MIT-LICENSE Readme.md -type f | sort`"))))
+          (add-before 'check 'remove-version-constraints
+            (lambda _
+              ;; Don't use specific versions of dependencies, instead
+              ;; take whatever is available in Guix.
+              (delete-file "Gemfile.lock")))
+          (add-before 'check 'add-mtest-on-PATH
+            (lambda _
+              ;; Tests use 'mtest' which is not automatically added on
+              ;; PATH.
+              (setenv "PATH" (string-append (getcwd) "/bin:"
+                                            (getenv "PATH"))))))))
     (native-inputs
      (list procps
            ruby-bump
-           ruby-byebug
            ruby-rspec
            ruby-wwtd))
     (propagated-inputs