summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-30 10:44:13 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:26:03 +0100
commitd3d4cdf26096f306b8c73286a9ce5e640c1b51af (patch)
treec2ad710915d52290b132a06d3c6779edbbdf26fa /gnu/packages/ruby.scm
parent3f14b1b4f70b111c39599cb7d80e698e4622740c (diff)
downloadguix-d3d4cdf26096f306b8c73286a9ce5e640c1b51af.tar.gz
gnu: ruby-stackprof: Always skip the GC test.
As this is very flaky.

* gnu/packages/ruby.scm (ruby-stackprof)[arguments]: Tweak skipping tests.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 024e436664..68db28eb17 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9213,15 +9213,12 @@ navigation capabilities to @code{pry}, using @code{byebug}.")
                  "mocha>.freeze, [\"> 0.14\"])\n"))))
           (add-before 'check 'skip-dubious-test
             (lambda _
-              #$(if (or (target-riscv64?)
-                        (target-ppc32?))
-                    ;; This unreliable test can fail with "Expected 32 to be <= 25."
-                    #~(substitute* "test/test_stackprof.rb"
-                        ((".*assert_operator profile\\[:missed_samples.*") ""))
-                    ;; This unreliable test can fail with "Expected 0 to be >= 1."
-                    #~(substitute* "test/test_stackprof.rb"
-                        (("def test_(cputime)" _ name)
-                         (string-append "def skip_" name))))))
+              (substitute* "test/test_stackprof.rb"
+                ;; This unreliable test can fail with "Expected 0 to be >= 1."
+                (("def test_(cputime)" _ name)
+                 (string-append "def skip_" name))
+                ;; This test often fails
+                (("def test_gc") "def skip_test_gc"))))
           (add-before 'check 'build-tests
             (lambda _
               (invoke "rake" "compile")))