summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 16:00:00 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:34 +0200
commit37fbced73c3aeb85472c1f3008eb32a2d87f67ef (patch)
tree3c5faf802c50d55794b228022fbd2e413b9e7e9c /gnu/packages/ruby.scm
parent770e3b535e0c90764ce58ee8bfb2d68bc0324f7a (diff)
downloadguix-37fbced73c3aeb85472c1f3008eb32a2d87f67ef.tar.gz
gnu: Add ruby-yard.
* gnu/packages/ruby.scm (ruby-yard): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c21e4cc2d4..7085adc1a0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5536,3 +5536,24 @@ support the tests found in Prawn, a pure Ruby PDF generation library.")
     (description "This is an experimental gem that extracts low-level PDF
 functionality from Prawn.")
     (license license:gpl3+)))
+
+(define-public ruby-yard
+  (package
+    (name "ruby-yard")
+    (version "0.9.16")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "yard" version))
+              (sha256
+               (base32
+                "0lmmr1839qgbb3zxfa7jf5mzy17yjl1yirwlgzdhws4452gqhn67"))))
+    (build-system ruby-build-system)
+    (arguments `(#:test-target "spec"))
+    (home-page "https://yardoc.org/")
+    (synopsis "Ruby documentation tool")
+    (description "YARD is a documentation generation tool for the Ruby
+programming language.  It enables the user to generate consistent, usable
+documentation that can be exported to a number of formats very easily, and
+also supports extending for custom Ruby constructs such as custom class level
+definitions.")
+    (license license:expat)))